FlightAware Discussions

Piaware is NOT connected to FlightAware - 2 Stations down

Two stations running Piaware 3.6.3 quit reporting several days ago and I am just now trying to figure out what to do. Piaware is receiving and displays aircraft on the map on the local network. Running piaware-status shows all is well except there is no connection to FlightAware. After rebooting and power cycling there still is no connection to FlightAware. My 1090 ADS-B and 978UAT stations have been down several days now. How can I do to get these two stations to reconnect to FlightAware?

piaware-status dump:
pi@piaware1090:~$ sudo piaware-status
PiAware master process (piaware) is running with pid 23635.
PiAware ADS-B client (faup1090) is running with pid 23653.
PiAware mlat client (fa-mlat-client) is not running.
Local ADS-B receiver (dump1090-fa) is running with pid 531.

dump1090-fa (pid 531) is listening for connections on port 30005.
faup1090 is connected to the ADS-B receiver.
piaware is NOT connected to FlightAware.

dump1090 is producing data on localhost:30005.

Your feeder ID is 59640abc-d579-4f36-a7da-13b78163bbb1 (from /var/cache/piaware/feeder_id)

Thanks - Tom KD5HM

Can you post the output of this command?

journalctl -u piaware | grep -v 'reported location\|--lat\|feeder ID'

The output is: “No journal files were found.”
Another oddity is that under Configure, I see the following error: “Sorry, the log appears to be empty at the moment. Please try again later.” Commands in the Configure window appear to do nothing.

Oh sorry, forgot the sudo:

sudo journalctl -u piaware | grep -v 'reported location\|--lat\|feeder ID'

No problem, missed the sudo as well. Note that I truncated the output below, as it continued for several screens with the “May 12 22:nn:nn piaware1090 piaware[532]: Connection attempt with adept server at 70.42.6.198/1200 timed out” message repeatedly. - Tom

Output from journalctl command:
– Logs begin at Sun 2019-05-12 22:22:11 UTC, end at Tue 2019-05-14 18:51:01 UTC. –
May 12 22:22:19 piaware1090 systemd[1]: Starting FlightAware ADS-B uploader…
May 12 22:22:19 piaware1090 systemd[1]: Started FlightAware ADS-B uploader.
May 12 22:22:22 piaware1090 piaware[532]: creating pidfile /run/piaware/piaware.pid
May 12 22:22:22 piaware1090 piaware[532]: ****************************************************
May 12 22:22:22 piaware1090 piaware[532]: piaware version 3.6.3 is running, process ID 532
May 12 22:22:22 piaware1090 piaware[532]: your system info is: Linux piaware1090 4.4.50-v7+ #970 SMP Mon Feb 20 19:18:29 GMT 2017 armv7l GNU/Linux
May 12 22:22:24 piaware1090 piaware[532]: Connecting to FlightAware adept server at piaware.flightaware.com/1200
May 12 22:22:24 piaware1090 piaware[532]: Connection to adept server at piaware.flightaware.com/1200 failed: couldn’t open socket: Name or service not known
May 12 22:22:24 piaware1090 piaware[532]: reconnecting in 57 seconds…
May 12 22:22:26 piaware1090 sudo[599]: piaware : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=list /bin/netstat --program --tcp --wide --all --numeric
May 12 22:22:26 piaware1090 sudo[601]: piaware : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/netstat --program --tcp --wide --all --numeric
May 12 22:22:26 piaware1090 sudo[601]: pam_unix(sudo:session): session opened for user root by (uid=0)
May 12 22:22:26 piaware1090 sudo[601]: pam_unix(sudo:session): session closed for user root
May 12 22:22:26 piaware1090 piaware[532]: ADS-B data program ‘dump1090-fa’ is listening on port 30005, so far so good
May 12 22:22:26 piaware1090 piaware[532]: Started faup1090 (pid 610) to connect to dump1090-fa
May 12 22:22:26 piaware1090 piaware[532]: piaware received a message from dump1090-fa!
May 12 22:22:57 piaware1090 piaware[532]: 426 msgs recv’d from dump1090-fa; 0 msgs sent to FlightAware
May 12 22:23:21 piaware1090 piaware[532]: Connecting to FlightAware adept server at piaware.flightaware.com/1200
May 12 22:23:21 piaware1090 piaware[532]: Connection to adept server at piaware.flightaware.com/1200 failed: connection refused
May 12 22:23:21 piaware1090 piaware[532]: reconnecting in 62 seconds…
May 12 22:24:23 piaware1090 piaware[532]: Connecting to FlightAware adept server at 70.42.6.224/1200
May 12 22:24:53 piaware1090 piaware[532]: Connection attempt with adept server at 70.42.6.224/1200 timed out
May 12 22:24:53 piaware1090 piaware[532]: reconnecting in 51 seconds…
May 12 22:25:44 piaware1090 piaware[532]: Connecting to FlightAware adept server at 70.42.6.198/1200
May 12 22:26:14 piaware1090 piaware[532]: Connection attempt with adept server at 70.42.6.198/1200 timed out
May 12 22:26:14 piaware1090 piaware[532]: reconnecting in 50 seconds…

Seems like you have no connectivity to flightaware.
Let’s check the routing:

sudo traceroute 70.42.6.224

Interesting…
gives me a “command not found” from the raspian console
When run from my Mac, traceroute fails after the 12th hop through 64 attempts:

traceroute to 70.42.6.224 (70.42.6.224), 64 hops max, 52 byte packets
1 192.168.1.254 (192.168.1.254) 0.765 ms 0.248 ms 0.184 ms
2 104-186-176-1.lightspeed.rcsntx.sbcglobal.net (104.186.176.1) 7.374 ms 10.947 ms 2.929 ms
3 71.155.29.86 (71.155.29.86) 2.014 ms 2.019 ms 2.198 ms
4 * * *
5 12.83.80.217 (12.83.80.217) 8.306 ms
12.83.80.221 (12.83.80.221) 5.721 ms
12.83.80.217 (12.83.80.217) 8.937 ms
6 12.123.18.29 (12.123.18.29) 139.562 ms 4.102 ms 3.821 ms
7 12.90.228.14 (12.90.228.14) 5.048 ms 5.084 ms 4.890 ms
8 border5.ae2-bbnet1.dal006.pnap.net (216.52.191.109) 4.423 ms
border5.ae1-bbnet1.dal006.pnap.net (216.52.191.44) 5.194 ms
border5.ae2-bbnet1.dal006.pnap.net (216.52.191.109) 4.179 ms
9 core3.te-0-0-0-2.hou-dalext1a-1.hou.pnap.net (63.251.44.42) 11.377 ms 11.162 ms 11.208 ms
10 border3.ae2-bbnet2.hou.pnap.net (216.52.168.65) 11.390 ms 11.392 ms 11.440 ms
11 edge1.ae1-edgenet.hou.pnap.net (23.92.181.18) 11.339 ms 11.099 ms 11.068 ms
12 superconnect-7.edge1.hou.pnap.net (64.95.211.202) 10.672 ms 10.718 ms 10.539 ms
13 * * *
|
64 * * *

That’s actually how it should look, the connectivity is fine.

That’s strange, let’s just install it and try again.

sudo apt-get install traceroute

This is probably your router running a captive portal of some sort.

pi is not having a good day, “sudo apt-get install traceroute” yields “E: Unable to locate package traceroute”

The router is an AT&T BGW210. This is a replacement router, provided after a firmware update bricked the initial router provided by AT&T…

A captive portal means you need to visit a website and enter a password or something to get Internet.
Does your router feature something like that?

Did you have static IP addresses configured by chance?
With a new router that might create problems if the new subnet is different.
(for example router might be 192.168.2.1 while the old router was 192.168.1.1)

The Internet is working for all connected devices other than the FlightAware Raspberry Pi’s. The old router both used the 192.168.1.1 subnet, as does the new router.

I will check the Raspberry Pi’s for fixed IP configs shortly.

“A captive portal means you need to visit a website and enter a password or something to get Internet.
Does your router feature something like that?”

No.

New router is 192.168.1.254

Can be seen in the traceroute :slight_smile:

So you’ll need to change the gateway and dns server to that IP address.

1 Like

The PiAware 3.6.3 status screen still shows “not connected to FlightAware” after modifying /etc/dhcpcd.conf to reflect the new router, gateway and DNS address 192.168.1.254, then rebooting the pi. The static ip assignment has been running fine since October 2016.

updated dhcpcd.conf ip settings:
interface eth0
static ip_address=192.168.1.7/24
static routers=192.168.1.254
static gateway=192.168.1.254
static domain_name_servers=192.168.1.254

Are other changes needed in dhcpcd.conf or elsewhere?

The router shows actual DNS addresses of 68.94.156.9 and 68.94.157.9. Should this be listed or 192.168.1.254 as shown above in the dhcpcd.conf partial listing?

Thanks,
Tom

Well if you change a router then the IP might change.

Change the DNS server to 8.8.8.8 and try again.

Added the following to dhcpcd.conf:
static domain_name_servers=8.8.8.8

The 3.6.3 status screen still shows “Not connected to FlightAware” error.

The PiAware 3.6.3 log shows:
Connection to adept server at piaware.flightaware.com/1200 failed: connection refused
reconnecting in 60 seconds…

Subsequent connection attempts show:
Connection with adept server at 70.42.6.225/1200 timed out

So the pi is reaching the server with a connection request and the server refuses the connection, or the attempt times out?

It’s more likely your router is not allowing the packets through.

Why not just use dhcp?
(The router might not allow devices internet without them using dhcp)

Or as i suggested install traceroute.
(Which probably won’t work either because your router is being an idiot)

What is the result of this command:

ping 8.8.8.8

The use of a fixed ip address for the Pi allows me to access PiAware from the internet using no-ip.com.

ping 8.8.8.8 works for the Mac. The pi shows packets transmitted, but 0 received, 100% packet loss.