FlightAware Discussions

Piaware is NOT connected to FlightAware - 2 Stations down

#21

Just looking around I found a query for the active name server: cat /etc/resolv.conf

returns: “nameserver 192.168.1.1”

Yet I have dhcpcd.conf setting the nameserver=8.8.8.8 . There is no nameserver assignment in /etc/network/interfaces. Any idea where this might be getting set?

#22

Did you do a reboot after changing the dhcpcd settings?

Or restart the dhcpcd service?

sudo systemctl restart dhcpcd

The pi can’t just magically guess that you change a configuration file :slight_smile:

Or maybe the dhcpcd configuration file didn’t actually get written?
(Problem saving due to not using sudo or something like that)

#23

Since you can’t find what is wrong with what you are running, why not burn a new piaware image and run that before you make any changes and see if it finds your network.

At least then you will know if it is the Pi or your network.

S.

#24

The reboot did the job and it is nice to see the pi is finally connected and logged into FlightAware.

Many thanks for your very perceptive and extensive help in tracking down all the issues!

1 Like
#25

Your idea of burning a new image certainly has merit. Since the first station is now running due to correcting IP settings to accommodate the new router, I believe updating the dhcpcd.conf file will likely also get the second station going. If not, I will likely take your suggestion and see how it works out. Thank you for the suggestion!

  • Tom