FlightAware Discussions

Trying to understand

Good afternoon,

The last week I have been experimenting with my gain. Today I changed my gain 49.6 back to the standard -10. And suddenly my ADS-B CPU utilization increased.
As I am trying to understand the graphs, is that “normal”
Thanks

One of the key indicators for gain setting is Messages > -3dBFS.
Around 5% of messages seems to be a good value, but depends on your proximity to a busy airport.

Nearest airports are about 150km/250km away. But both are not in my coverage range.

“-10” is max gain. If you have any interference in your area, increasing the gain will give you louder interference. So, your Pi is likely getting more signals (of all types) with the higher gain setting, but if your plane count and message count didn’t change, then those extra signals are probably garbage - but it needs to be processed to make sure it’s garbage, so more CPU usage.

Thank you very much. Now I understand what happened.
So next step will try to find out my interference:) Will check again as you suggested, count and messages.

ADS-B tracks increased after changing to -10

Thanks again

I prefer not to use the -10 max gain so that single-track messages are kept to a minimum and the range of signal levels detected is as wide as possible.

The primary value for keeping an eye on is the value for Messages > -3dBFS
This should be below 5% as a rule of thumb. -10 is normally not a good idea


You will need a certain amount of traffic, otherwise the values are inconsistent if traffic changes.

I left my gain at 40.2. I could go higher, but it won’t change anything in reception. Once the traffic comes back, it is the best value for my location/setup

In general i would start in the mid of 40s and then doing on step up or down and leave it for a full day at this value for further verification.

It also depends on your equipment. I am using the blue Pro Plus stick, a normal SDR can require a higher value, if used an additional LNA it can be lower.
It’s mainly a try&error

Thank you very much for the explanation. Again a step forwards for me. It is much appreciated.
I noticed that after my change to -10 the single messages rate went up., but could not explain it. Thanks to you, now I do:)

@foxhunter
Thank you for the help. I will try and have a lot of erorrors:O
I use a RTL_SDR dongle, with a Jetvison antenna. So will start as you recommended somewhere at 43 and than see what will happen.

Thinking of buying a filter as well. I am living in a city, so from what I read it should be very useful. Thinking about the Uptronics filter.

Thanks again

Filter and LNA will improve your reception.

You can find more information in this thread. But careful, it requires some long winter evenings to read :slight_smile:

@foxhunter

I already started reading that thread. But being a completely non tech guy, it takes extra time and lots of more reading and re-reading.

Will start with the Uptronics 1090 Mhz filter. Read that this one is not getting that warm and Wiedehopf stated that the new RTL filter seems to be not as good as the previous one. Cannot recalls where he wrote that., somewhere here in this forum…

First step today, to change my gain.

Thanks for your time and help

That’s a good starting point

I did the same way. Simply build my first receiver 18 months ago and after it started working i began optimizing it.

If you read too much at the beginning, it can confuse you. It also heavily rely on your environment

@foxhunter

You are right. I try/tried to read as much as possible, but that makes me even more confused.:frowning:

Since this morning I rplayed with gain between 40 - 49.6. Around 40 almost all planes are gone and the range dropped as well, so I will go up.
Checking the strong messages,…pffff they stay at 0,000 percentage with:
awk “$(cat /run/dump1090*/stats.json| grep total | sed ‘s/.accepted":[([0-9]).strong_signals":([0-9]).*/BEGIN {printf “\nPercentage of strong messages: %.3f \n” , \2 * 100 / \1}/’)”

Suggesting -10 is bad without knowing the setup … isn’t recommended.

Also the graph he posted already showed that -10 wasn’t too strong.
Non-amplified receiver: needs -10 as gain.

I am facing another problem. Made a mistake while trying to change my gain.
Saw this error:

Tried to update and restart dump1090 in Flightawre. Was successful.


But still I see the error.

Guess something is Wong in my sudo nano /etc/default/dump1090-fa

IS there a way yo correct this error?

Used the commands given by Wiedehopf

Your content in the receiver options line look messed up. It says “-10gain” which is not readable.

Mine:
RECEIVER_OPTIONS="--device-index 0 --gain 42.1 --ppm 0"

You should fix that and restart it again.

As stated by @wiedehopf it depends on your setup. Antenna indoor/outdoor, Antenna optimized or not, General RTL stick or specialized (e.g. the FA stick), LNA/Filter yes-no…
Even the cabling or connectors can be an issue

@foxhunter

Thank you very much, copied and paste the file and saved it in a safe place.
It is working again. Deep bow!