FlightAware Discussions

Huge increase on "bad" messages > -3dBFS after gain adjustment from 49.6 to max

While seeking an optimal gain, I changed it from 49.6 to the max value. With 49.6 the “bad” signal ratio was close to 2-3%. After change to max, it went above 10%.

Are there any ways to adjust the gain more granularly? I realize the “standard” steps are 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6 and max.

My hardware is a blue FA dongle with a dark blue FA filter. My radar is located in a mid-sized town, however very close (100 m) to a GSM tower.

No.

Anyhow 2 percent isn’t something you need to change.
Also … calling those signals bad doesn’t really make sense :slight_smile:

What are the reds then? (I’m not a techie in terms of radio communications :wink:
Based on what I read on this forum, It assumed it’s reasonable to keep this ratio below 5% in general.

They are stronger than -3 dBFS :wink:
so -40 is a very weak signal, -1 is a very strong signal.

Maybe just read the first 2 posts of this thread:
(or the whole thread :wink: )

To really understand what is going on, you need quite a bit of physics background.
Well at least it helps understand the units :wink:

dBFS for example is something you can google.

I did read this topic before posting mine, however it seems to exceed partly my mental capacity ;-).
My understanding is as follows:
If I increase the gain, I’m able to catch weaker signals. The downside is, however, that I also get more noise and interferences by increasing the gain value. So the aim of finding the optimal gain value is to get a balance between being able to catch weaker signals on one hand side and void too much interferences on the other hand side.
Is that more or less correct or did I mess it up totally? :wink:

Well that’s not true either.
Above a certain gain, you might just get more internal noise, but not more real signal.

No not really.
You don’t want the planes close by to overload your receiver.
Low and close flying planes are in the horizontal plane of the antenna (roughly).
Those can overload the receiver, you would see it on the local map as the track is interrupted.

And generally, with >5% of the red messages, often the message rate from close by planes goes down.

Put it back to 49.6, You will not have less range or aircraft recorded.

While my device was indoor i played around a lot with gain. There was not much difference with settings between 43.9 and 49.6
But setting it to max clearly dropped the number of messages overall.
Test every setting for a day and you will find it by yourself.

Currently it’s not a good timing as based on Corona the overall amount of aircraft and messages is decreased

1 Like

Oh yes, due to corona there is no reliable comparison to previous periods of time given. Hope on stable traffic pattern to get back soon :wink:

To test “max” set it to -10 then the gain query will display “max” in your terminal.

I’m also using 49.6 for my Nooelec SDR.

I am sure you know what i meant :wink:

1 Like

-10 seem to be at least 55 or something.

The impact changing from 49.6 to it is huge compared to any other setting below that value.
Or in other words: the difference between 43 and 49 is lower than between 49 and -10

Not correct. PiAware sdcard images interpret “max” as -10 (because this is how you get the maximum gain setting out of a stock librtlsdr for ADS-B signals). See https://github.com/flightaware/piaware-support/blob/master/scripts/generate-receiver-config#L66

The difference is, in theory, 3 VGA gain steps @ nominally 3.5dB/step.
See https://github.com/osmocom/rtl-sdr/blob/master/src/tuner_r82xx.c#L977 (VGA gain register = 8) vs https://github.com/osmocom/rtl-sdr/blob/master/src/tuner_r82xx.c#L1014 (VGA gain register = 11)

If you pass any non-number as an argument to --gain on the dump1090-fa command line, it will result in a gain of 0. (Really, it should reject it entirely). --gain only understands numbers.

1 Like

There are statemenes in this forum it’s something around 55

There are also statements that it’s more. 58 59 60

1 Like

wow, did not see them. Thanks

You cannot set maximum gain via --gain and a number. If you’re interested, please look at the piaware-support package to see how it configures dump1090-fa.

I don’t understand what you are asking.

setting it to “-10” gives you the max. If you want to know the real number, try it out by increasing it step by step. But it could be that manual settings > 49.6 are simply ignored

Well, except you can get a higher effective gain than 49.6 by abusing the AGC setting.

2 Likes