FlightAware Discussions

Lots of single message tracks

Hi All,

Been tracking on and off over the year but only now starting to look into improving my setup. Started off with a low cost usb stick with one of those tiny antennas, I cut the length to 52mm as suggested on a few forums with respectable results considering it was just placed beside my bedroom window.

I’ve since purchased the FA pro plus and installed an AirNav antenna at high level outside (cant get up to the chimney yet which will be my next improvement), I’ve also installed graphs1090 and a few scripts to check on noise etc. After checking the new noise graph I could see lots interference from the GSM bands here in the UK between 800-820MHz and 920-940MHz, purchased the light blue FA filter which has cut out the lower band but not the 920-940MHz, have purchased the newer filter (dark blue) which has a narrower band and should in theory cut out all of the GSM noise.

One thing i need advice on is my performance charts. Im seeing a huge amount of red single message tracks, is this normal?

Capture

My current setup is Rasp Pi Model 3B+, Piaware 3.8.1, dump1090-mutability, multiple feed sites.

Thanks.

dump1090-mutability is unmaintained. Try dump1090-fa or readsb to begin with.

will do, update to follow soon!

Once you updated this, take a closer look into these threads

Thanks for the pointers, think I’ve scanned over these the last few days. Waiting on my dark blue filter to be delivered, should have it installed by mid next week. Been messing with the gains to try and improve on the single tracks but nothing seemed to make much difference, Ive just installed dump1090-fa and im in the middle of trying to get my graphs back up and running, will give you an update once done, doesnt help when you missus is frowning at you for being on the laptop all the time ;-).

Capture1

Unfortunately still the same, do you think its the noise form the GSM bands?

Next question is, what’s your software config exactly (what arguments are you starting dump1090 with?)

Yeah, change gain to 38 and show the the main and range and signal level graph as well.

Dump Config:

dump1090-fa configuration

This is sourced by /usr/share/dump1090-fa/start-dump1090-fa as a

shellscript fragment.

If you are using a PiAware sdcard image, this config file is regenerated

on boot based on the contents of piaware-config.txt; any changes made to this

file will be lost.

dump1090-fa won’t automatically start unless ENABLED=yes

ENABLED=yes

RECEIVER_OPTIONS="–device-index 0 --gain -10 --ppm 0"
DECODER_OPTIONS="–max-range 360 --fix"
NET_OPTIONS="–net --net-heartbeat 60 --net-ro-size 1300 --net-ro-interval 0.2 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 --net-bi-port 30004,30104 --net-bo-port 30005"
JSON_OPTIONS="–json-location-accuracy 1"

This is the graphs from last night gain setting was at -10

Have now set the gain to 38 and will upload the graphs in 2 hours, thanks.

gain at -10 is normally never a good value for it.

Depending on where your antenna is located a gain setting between 40.2 and 49.6 should match best.
But simply start with the suggestion of wiedehopf and monitor it for a couple of hours.
Be aware that it’s not reliable while having low traffic. Could be that you need to verify it longer than 2 hours.

Possible gain settings:

20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6

Yeah I’ve tried all sorts of gain settings from your list, no matter if I drop it to 20.7 I still get masses of red single tracks. I just thought it was normal until I started looking at other peoples graphs. Does the config file above look nomral to you? thanks.

Is this not related to the --fix option?

Capture3

From 9:50 the gain was set at 38.6.

I did read something abot the --fix option but I dont quite understand if its needed or not or what exactly it does.

It enables error correction. I was getting a lot of single messages and now have it turned off on both mine because it makes it hard to understand what is going on.

This is mine if you want to compare it. I am using it with an outdoor antenna plus an additional 1090MHz Filter
That’s why i am able to set the gain that high

# dump1090-fa won't automatically start unless ENABLED=yes
ENABLED=yes

RECEIVER_OPTIONS="--device-index 0 --gain 49.6 --ppm 0"
DECODER_OPTIONS="--max-range 360 --fix"
NET_OPTIONS="--net --net-heartbeat 60 --net-ro-size 1300 --net-ro-interval 0.2 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 -$
JSON_OPTIONS="--json-location-accuracy 1"

looks a little better, this is with --fix deleted and a gain of 40.2

Capture4

It’s unusual to see the huge number of single-message tracks you saw in your earlier graphs even with --fix enabled. It’s more likely at higher gains, but even then… Maybe just something unusual about your RF environment.

1 Like

It look better, but it might not. The amount of “green” tracks is similar to the previous graph.

Agreed but the CPU utilisation has dropped by approx 10% no longer needs to deal with the noise. Waiting on my new dark blue filter next week, will see how things improve when I can filter all these mobile signals.

You haven’t posted the signal strength graph and the new message rate graph :stuck_out_tongue:
(after changing the gain)