FlightAware Discussions

Stop SkyAware?

I have a spare Raspberry Pi that I was using as a “MagicMirror” and I thought I’d add it as a flightaware feeder. Anyway, after installing FlightAware “SkyAware” has taken over 127.0.0.1:8080.

Is there a way I can reconfigure so I can get my old MagicMirror back and still run FlightAware in the background?

Thanks.

sudo lighttpd-disable-mod skyaware

Or edit /etc/lighttpd/conf-available/89-skyaware.conf to remove the port 8080 config stanza

Thanks - I tried both that command and #'d every line in the 89-skyaware.conf file, but going to 127.0.0.1 still shows SkyAware.

Sometimes the cache loads old stuff.

Try clearing that, might work.

Geoff

Thanks, no luck. Might skyaware have overwritten the webpage that was originally hosted?

It’s a config that affects lighttpd which needs to be restarted to see changes.

Ok, so in etc/lighttpd there are 2 folders and 1 file:

conf-available
conf-enabled
lighttpd.conf

In both conf-available and conf-enabled there is the file 89-skyaware.conf

I’ve #'ed every line in both files.

I’ve also ran sudo lighttpd-disable-mod skyaware

When I type “npm run start” (the command to start Magic mirror) the Raspberry pi still goes into a full screen display of SkyAware. The one thing that has changed is that 127.0.0.1:8080 now yields “this site can’t’ be reached”. However SkyAware is still lurking somewhere in the background because I can’t start MagicMirror.

Just reboot, seems my explanation didn’t take.
(the key was to restart lighttpd, it’s a service … how to restart it, well google something like “restart lighttpd”)

Oh, sorry. Yes, multiple reboots yield the same thing. On startup, a script runs to start magic mirror. Instead of a full screen of magic mirror, I get a full screen of piaware, skyaware.

is there a 89-dump1090-fa.conf there?
And where on :80 or :8080 ?
Which screen do you get exactly, provide a screenshot.
It has to be in one of the configuration files, look for 8080 if that’s the port you care about.

What port was magic mirror on, :80 or :8080 ?

Not sure how you access your Pi but if you ssh into it then type sudo netstat -tulnp it will give you a list of port numbers and what program started the ports.

Geoff

Thanks. Yes, it appears port 80 is still in use by lighttpd.

This is what loads every boot. I use both vnc and ssh to access the pi.

Well, sure. You didn’t say anything about needing port 80, you said you needed to turn off port 8080.

It looks like nothing is listening on 8080 now so it’s working as expected - lighttpd has bound port 80 only and is leaving 8080 free for whatever you needed there.

If you want to entirely stop lighttpd from taking any ports including port 80, then try sudo systemctl mask lighttpd and reboot.

Having lighttpd still available is nice.
Changing server.port in /etc/lighttpd/lighttpd.conf to for example 81 seems like the more sensible approach :slight_smile:

Where does that load?
You must have some custom modifications to automatically open a browser?
You’re not even showing the URL that is accessed.

Or is that this strange stuff from that other software that opens that browser?

So, I entered this:

…And rebooted. I got this result.

I expected to see my magic mirror load which looks something like representation.

Admittedly I’m a cut and past kind of guy but I’m learning, This is a sample from the config file for my magicmirror. You can see the reference to port 8080. That’s why I assumed that. Thanks for helping troubleshoot.

Seems that magicmirror is using lighttpd as well.

Any chance you need to activate the lighttpd config for it?
You’ll also need to unmask lighttpd … if it uses that indeed.

Annoying, guess you didn’t have backup of Magic Mirror. Sometimes the easiest remedy is a reload. I have found in the past the time spent trying to sort out a problem is better spent reinstalling. Not always practical, appreciate that. Installing PiAware on a blank disk is easy and not too time consuming, the magic mirror I’ve never tried and may be an issue.

Geoff

Thanks… yeah, I might have to reformat. I’m not sure what piaware did to the setup but it certainly seems to have overwritten something. No, no backup for my original installation. I was just using magicmirror as an electronic “picture frame” and thought it’d be easy to just slap a FlightAware dongle in to add a feeder. Well, it WAS simple to get piaware running… but at a big cost to my time now.