Change port of PiAware Skyview?


#1

Is it possible to change the port that the PiAware Skyview web UI is available on?

When the setup scripts executed it installed it on 8080. If I want it to just respond on good old 80, can I do this? If so, how?

I found this? Change port 8080 on PiAware 3 but my lighttpd appears to already respond with a default lighttpd page on port 80???

server.modules = (
        "mod_access",
        "mod_alias",
        "mod_compress",
        "mod_redirect",
) 

server.pid-file             = "/var/run/lighttpd.pid"
server.username             = "www-data"
server.groupname            = "www-data"
server.port                 = 80


index-file.names            = ( "index.php", "index.html", "index.lighttpd.html$
url.access-deny             = ( "~", ".inc" )
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

compress.cache-dir          = "/var/cache/lighttpd/compress/"
compress.filetype           = ( "application/javascript", "text/css", "text/htm$

# default listening port for IPv6 falls back to the IPv4 port
include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
include_shell "/usr/share/lighttpd/create-mime.assign.pl"
include_shell "/usr/share/lighttpd/include-conf-enabled.pl"

#2

Have you tried changing the port in /etc/lighttpd/conf-enabled/89-dump1090-fa.conf and restarting lighttpd?


#3

That worked! Is this documented somewhere? Or just tribal knowledge?


#4

I don’t know that it is documented in the FlightAware universe. I’ve just spent quality time with lighttpd since I have a Raspberry Pi 3 server that collects temperature/humidity data from numerous RPi’s around my house, plus motion-detected webcam photos of wildlife outside my house, and the occasional UPS delivery to my porch. I serve these on an internal webpage and I’ve been using lighttpd for it for several years.

I also run an OpenVPN server and use duckdns.org for dynamic dns so I can access my local network from outside (to see my SkyView page, internal webpage, and access everything remotely). The OpenVPN also gets used when I’m on public wifi so all my communications are encrypted and get routed through my home fiber connection.