FlightAware Discussions

Some sort of coverage radius?

After a bit of browsing, i noticed, some people could get some sort of coverage radius on their maps, where they could see, what areas are covered in which directions, but i never found any way to install that for myself, or if i found something, it was always too old.

Are there any ways to have such map shown with an antenna coverage radius of some sort?

1 Like

For example ModeSMixer2
https://radarspotting.com/forum/index.php?topic=2978.960

1 Like

https://github.com/wiedehopf/tar1090#heywhatsthatcom-range-outline
https://github.com/wiedehopf/tar1090#a-separate-instance-with-longer-data-retention-for-gauging-range

This results in this:

1 Like

It’s amazing how well the whatsthat range outline matches with the tracks.

That’s exactly what I was looking for @wiedehopf!

Thanks!

You can also filter by altitude (in persistence mode it will filter the tracks instead of filtering the planes):

1 Like

The first reply was exactly, what i was looking for, however there were no usable guide to install that.
With the second one, i installed that and i will probably see in around 24hrs, what my results are.

Real coverage or the theoretical coverage in your area?

the first one can be done via ModesMixer (what was mentioned already) or by running a VRS instance, there it looks like this (my local install, colors are adjustable)

If you want to have the max. range you can get as a static line, this is done by getting the json file from heywhatsthat.com and implemented in your install.

There should be a howto here in the forum, if i only know where… :face_with_monocle:

You can check after an hour or two and you will have a good picture granted you have some traffic.

That map above is pretty much, what i am looking for.

After setting up the persistant site, the site is now in a reload loop without able to show me anything for the past 2 hours.

you mean the one i have posted? This is the result of now almost 2 months where VRS is running.

But i don’t know if all data is used or only the last xx days.

Oh, just realized you mean the map above. Sorry.

You could also feed to opensky-network.org. They provide a similar map shown in the receiver profile, but it resets once a day and it cannot be used locally.

I got one of the maps running now, but the one, that’s supposed to show history is just in a constant loading loop without showing anything.

That’s usually a user error.

What did you put into the tar1090_instances file?

image

This is, what i have put into the Tar1090 instance file.

Looks correct …
Not sure why it wouldn’t work.

Maybe an error in the other configuration file you edited?
Usually it works nicely.

But /tar1090 works?

Can you describe your install (image, decoder used …)

/tar1090 works, as seen in this picture,

, And there was only another file i edited, which was the persist file for the history data.

Well then that’s likely the issue.

I’ve always used Al’s overlay - mostly because of the range, but also because I like how it sorts Military - So here is another idea if someone wants to use:

From my notes (this is not a script)

#############################################################
#                     AL's MAP OVERLAY
#   https://github.com/alkissack/Dump1090-OpenLayers3-html
#############################################################

sudo git clone https://github.com/alkissack/Dump1090-OpenLayers3-html.git /usr/local/share/alkissack/

sudo tee /etc/lighttpd/conf-available/88-al.conf >/dev/null <<EOF
#lighttpd configuration for alkissack interface
alias.url += (
  "/al/data/" => "/run/dump1090-fa/",
  "/al/" => "/usr/local/share/alkissack/public_html/",
)

# redirect the slash-less URL
url.redirect += (
  "^/al$" => "/al/"
)
EOF

sudo lighty-enable-mod al
sudo systemctl restart lighttpd
ID="<YOUR.UP.IN.THEAIR.ID>"
sudo wget -O /usr/local/share/alkissack/public_html/upintheair.json "http://www.heywhatsthat.com/api/upintheair.json?id=${ID}&refraction=0.25&alts=3048,12192"

sudo nano /usr/local/share/alkissack/public_html/config.js
<CHANGE SETTINGS AS YOU NEED>

Interface will be available at
http://<address>/al

On the site of the tar1090 it said something about changing said things in the picture to these variables, so i did thatimage

And i guess, AI’s overlay just has to be followed as below?

So for the instances file you added extra empty lines, maybe that created an issue, so remove that file:

sudo rm /etc/lighttpd/conf-enabled/88-tar1090-.conf

I’ve added a check to the install script so empty lines are ignore now.

You can try rerunning the install script, it will keep the settings you changed.
Also try a reboot.

Apart from that we can check some more stuff if it’s still not working and you want to try and fix it.

88-tar1090-.conf is stated as not existing in my pi
(No such file or directory.)

Also, after testing the AI’s overlay, i just get a blank webpage without any data.