FlightAware Discussions

[SOLVED] Bug positioning with PiAware Skyview using an OrangePi

Hi all,

I am facing an annoying bug about the location of the site displayed in Skyview.
I use two stations, having the same position. The first is built with a RaspberryPi, the second is made with an OrangePi Zero (using Debian Stretch). Both works very fine, with the latest PiAware software (3.7.1), except one thing:

With the OrangePi, the position of the station is wrongly displayed in Skyview.

As you can see below, only the station position is affected, not the aircrafts position. I’ve take a snapshot, showing the station position, and an aircraft track. This one is accurate on both station. The problem is strange because it affect only the “black point” location.

This is definitely not a problem of configuration, I’ve checked again, and again, the station position is correctly defined. Using the Flightaware web (my ADSB), the position is fine. I’ve also verified with /var/cache/piaware/location.env… all is correct.

Position of the first station (Raspberry Pi):

Position of the second station (Orange Pi Zero):

As you can notice, the green track (on top right) on both snapshots is the same, so the aircraft positions on both station are the same, no issue with that.

After many investigations, I’ve found what was wrong : on the Orange Pi, the position is truncated/rounded while not with the Raspberry Pi. I’ve compared with Google Maps to found the coordinates of the wrong position : It is exactly as if it was rounded with only two decimals. Ie, it use 48.99 , 2.22 instead of 48.98761 , 2.2207

What is surprising, is that the aircrafts positions are correct, not rounded.

So, I suspect that there is an error when reading the configuration file.
As this work fine with the Raspberry Pi, I think that the problem is with a default setting when compiling/installing the software for the Orange Pi. May be a variable, or a system setting, or a package configuration. But where ?
What function use Skyview to read the configuration file ? quite sure, the issue come from here, using a rounded value instead of a full decimal value.

root@pi ~: dump1090-fa --help
[...]
--json-location-accuracy <n>  Accuracy of receiver location in json metadata: 0=no location, 1=approximate, 2=exact
[...]

default configuration in /etc/default/dump1090-fa

JSON_OPTIONS="--json-location-accuracy 1"

Change it to 2 to fix your problem.

2 Likes

:+1: Many thanks for your very fast and accurate reply.

Indeed, it was obviously related to JSON but I’m stupid :man_facepalming:, I had not the idea to look at the dump1090-fa configuration file.
Problem is solved, now the position of my second station is correctly displayed in Skyview. :sunglasses:

Thanks again.

The default position is rounded like this to make it less likely that someone will unintentionally leak their exact home address without realizing it by sharing their skyview display.

2 Likes