FlightAware Discussions

Skyaware display issues

I am running skyaware and flight aware ver 3.7 on a raspberry pi 3+and when I go to the IP address of the pi using a windows OS and select skyaware the make works perfectly. When I use another pi 3 + or a 4 the skyaware screen has many of the same images. I have searched the internet and flight aware discussions and can’t seem to find an answer to resolve this.

73
Tom

Provide a screenshot please.
Try Ctrl-F5.

Here is the screenshot… the background is wrong and sometimes is shows partially in the correct lat and long

Did you try a different browser/device to connect to this map?

Seem to be a display issue caused by caching in Browser. Are you able to zoom in/out?
As far as i know the map is not part of the local install, it’s loaded on demand via internet

Not caching, the browser probably is just not working correctly.
Try installing chromium.

Ok thank you… I loaded Madori and it works well. Appreciate the help

73 and Happy holidays and a safe new year

Tom

I’m running piaware 3.8.1 on a PI 3B model.

At the beginning the map was full of planes but now there a just a few, despite the position data should be received correct.
typical_map
just a few planes are shown and most of them look like timed out

Clicking at the “ICAO” number of the flights on the right side displays the corresponding flight so I can browse through the flight lest and I will get the choosen flight on the map.

I also set up the PI in a new configuration (new SD card, new image) but it didn’t work.

I pressed CTRL-F5 as well as different browsers and computers

Any ideas??

Most probably hardware failure (dongle, cable, antenna, power) if it was previously working.

I cannot see a hardware problem:

  1. lot‘s of flights on the list at the right side with background-white with position data and background-blue without position data
  2. still transferring data to flightaware keeping a ranking at about pos 4000.
    despite all the map still shows just 3-4 of the flights in total and moreover most of them seem to be timed out

Have you cleared your browser’s cache and refreshed the page?

7 messages per second is very weak reception.
All the aircraft are timing out.

Fix your power supply or get a new SDR, one of those is likely the issue.

1 Like

I just changed both (powersupply and Flightaware Pro Stick) but result is still the same


what also looks strange is the daily total of tracked positions (right side about 50.000 a day) compared to the few positions displayed on the graph left side. In the beginning there where some 20.000 at the 2nd/3rd graph and now it less than 10.000 per column.

Did the message rate increase?
Your reception is still bad i’d be fairly certain.

Install the graphs and post them: https://github.com/wiedehopf/graphs1090#graphs1090

My bet is that some interference source has been added.
Or you broke your antenna coax or sth.

2 Likes

Try a gain of 43.9, post another set of screenshots after a couple of hours or later.
For Beginners - How to Set / Change Gain

To be honest the message rate is bad even for the gain being too high.

I’d expect you have some strong interference and need a filter.
https://github.com/wiedehopf/adsb-wiki/wiki/Useful-items-for-purchase#filters-germany

Do I Need A Filter?

Honestly in such cases you basically try a filter and hope that i helps.

had made a mistake first with the 43.9. That’s why I deleted the post above.

Well, setting the 43.9dB at 16:00 these are the results

Grafik-3

So You still recommend a filter - or shall I start some frequency scans before?

leave it with this value for the next 24 hours.
With this low traffic at the evening it is a mission impossible to determine the correct gain settings.
Your first plot shows too much gain. After i got my new Jetvision antenna i needed to reduce it down to 40.2 which gave me the best value keeping an eye on the messages > 3dbFS (should be max 5%)

Now i am using a FA filter between antenna and blue FA stick.
Gain back to 49.6, but the messages > -3dbFS stayed below the “magic” 5%

But the low overall traffic makes it hard to determine if right or wrong.

This is the graph with the time i installed the filter. before that gain was at 40.2
Consider the small peak the same day in messages > -3dBFS
I had gain set to “-10” for a few hours, but it did not work, so i went down to 49.6 which seem to be fine now.

Looking at the ADSB Signal Level chart, the early part of the light blue line shows unusually high levels. This is the minimum signal level seen at the receiver. This implies to me a high level of background noise/ interference. That level could easily mess with the ADSB signals. When you reduced the gain, the minimum signal level reduced and the higher levels changed but into a more normal range. My FA receivers seem to have the light blue line around -24, my airspy receiver drops to about -30.

You may need a filter before the receiver as Foxhunter mentioned. Good idea to run a scan of signal levels to get an idea of what is affecting your reception. I ran one before buying my filter, and it showed heavy interference around the 900Mhz band. Have fun with it, always things to learn working with this stuff.

I was running a scan before and after the filter attached. i’ve documented this also in the long thread “Do i need a filter?” with lots of information in it.

You can see the areas of unwanted signal in the picture “without filter”.

image

1 Like