Run Piaware from Win/Mac Laptop/Desktop - Absolutely No Software Installed on Hard Drive


This method uses installation of Linux OS “Raspbian PIXEL x86” + dump1090-fa + Piaware + other data feeders, on a USB Flash Memory Stick.

After installation is complete, plug-in this USB Flash Memory stick in a Windows/Mac Laptop/Desktop, and restart the Laptop/Desktop, and at Boot time, choose option to boot from USB Flash Memory Stick.


It is highly recommended by Flightaware to disable MLAT if you are moving in a car with your Laptop, as location is changing continuously, which will make MLAT to give wrong results. You can Enable MLAT if
(a) your car is parked,
(b) you enter the current location coordinates by going to


(A) Installation of Linux OS on USB Flash Memory Stick

(1) On Windows/Mac laptop, download

(2) Plug-in a USB flash memory stick (8Gb or more) in laptop/desktop and format it.

(3) Write the downloaded .iso image to USB flash memory stick using Win32 disk imager or etcher.

(4) Shutdown laptop/desktop, and power up again. At start up, enter option to select boot device, and select USB flash memory as the boot device and boot from it into a Raspbian Pixel style desktop.

Different models of Laptop/Desktop use different methods to get into boot device selection. Most popular is to Press F12. On some models Escape then F9. Some Models may have still a different method to get into boot device selection at startup.

CAUTION: The default startup mode for Raspbian Pixel x86 is “With Persistence”, which on shutdown/reboot retains all the software installed and all the files saved. Without user interference, the Pixel x86 boots automatically to default of “With Persistence”. However if you are curious to see, at Raspberry Pi Splash screen press “Escape”, button, all available options will appear. DO NOT choose “Reset Persistence”, as it will wipe out all installed software like dump1090-fa, Piaware etc. Choose option “With Persistence”.

(5) Enable WiFi
From network icon on top-right of the Desktop, (1) right-click then selecting interface configure network, select Interface wlan0 (2) left-click and turn ON Wifi, then again right-click and it will display list of available WiFi networks.Choose the one you want to connect.

(6) Enable SSH
By default both the “SSH” and “SSH Password Authentication” are blocked. take following steps to enable these.

(a) To enable SSH:

#from terminal window of PIXEL x86 Desktop
#create file ssh to enable ssh

sudo touch /boot/ssh

(b) To enable Password Authentication for SSH:

#edit file sshd_config to enable ssh login
sudo nano /etc/ssh/sshd_config

Press Ctrl+w and type PasswordAuthentication and press Enter key.
The cursor will jump to line PasswordAuthentication no
Change no to yes
Save file, exit nano, and reboot

sudo reboot

(7) Change Keyboard from GB (default) to US
The default keyboard layout is GB. If you use a US Keyboard layout, you will see following differences in the default keyboard keys
Shift+2 will print “, and not @
Shift+3 will print £ and not #
Shift+” will print @ and not "

Since the tool “sudo raspi-config” is not available to change keyboard/locale, take following action

(B) Installation of Decoder and Data feeders on USB Flash Memory Stick

Before starting installation of dump1090-fa (or dump1090-mutability) and Piaware and other data feeder, plug a DVB-T or ProStick or ProStickPlus into your Laptop/Desktop which is running Raspbian Pixel x86 from USB Flash Memory Stick.

Do NOT install piaware by package install method on this page. It fails.

The reason is these packages are built for ARM architecture (Raspberry Pi), whereas laptops have i386/amd64 architechture.

To install dump1090-fa (or dump1090-mutability) and Piaware data feeder, I build these from source, using J Prochazka’s scripts. Since these packages were built right on the laptop, these were built for the architecture of the laptop (i386/amd64).

sudo apt-get update
sudo apt-get install git
cd ~/
git clone

The use of Joe Prochazka,s script required two workarounds:


Update software versions in file ~/adsb-receiver/bash/

#open file for editing
sudo nano ~/adsb-receiver/bash/

In the file, make changes in version numbers as shown below:


Build and install bladeRF and its dependencies.
Execute this workaround only if you want to install dump1090-fa.
For dump1090-mutability omit this workaround.


sudo apt-get update
sudo apt-get -y install git
sudo apt-get -y install debhelper
sudo apt-get -y install cmake
sudo apt-get -y install libusb-1.0-0-dev


sudo apt-get install -y doxygen
sudo apt-get install -y libtecla-dev
sudo apt-get install -y libtecla1-dev
sudo apt-get install -y help2man
sudo apt-get install -y pandoc
sudo apt-get install -y libncurses5-dev


sudo mkdir ~/build-bladeRF
cd ~/build-bladeRF
sudo git clone
cd bladeRF
sudo dpkg-buildpackage -b


sudo dpkg -i ../libbladerf1_*
sudo dpkg -i ../libbladerf-udev_*
sudo dpkg -i ../libbladerf-dev_*

Final Step After Workarounds:

Run the installation script:

cd ~/adsb-receiver
chmod +x

A interactive dialogue will appear, follow instructions on it.

NOTE: During this interactive process, one option given is "It is highly recommended to update your system " but it actually upgrades your system.

This update/upgrade takes considerable time to complete, some more space on USB Flash Memory, and also drains the Laptop Battery during normal use due to unnecessary packages are running in background. I said “NO” to it and still my setup is working ok.

Flightaware prostick plus help needed!

Clock Problem and Workaround in Dual Boot Systems:

When you boot your Laptop/Desktop to Windows on its Hard Drive, its clock shows local time.
When you boot your Laptop/Desktop to Linux (Pixel x86, Debian, Ubuntu etc) on USB Flash, its clock shows UTC time.

Not only this but if you are using Ubuntu or Debian on USB Flash drive, and after you finish using it, and boot to Windows, it also starts showing UTC time, which is unusual for Windows users.

This is caused by the fact that Windows and Linux both read & set hardware clock / BIOS clock. The problem comes because Windows reads/sets hardware clock time as local time, while Linux reads/sets it as UTC.

The problem can be overcome by following method which makes Linux to behave as Windows and to read/set hardware clock in local time instead of its default UTC.

#Check setting is local o r not
pi@raspberrypi:~ $ timedatectl | grep local
 RTC in local TZ: no

#If "no", set it to local
pi@raspberrypi:~ $ timedatectl set-local-rtc 1

#Now check again, it should say "yes"
pi@raspberrypi:~ $ timedatectl | grep local
 RTC in local TZ: yes
Warning: The system is configured to read the RTC time in the local time zone. This
         RTC in UTC by calling 'timedatectl set-local-rtc 0'.


Note that this will break over daylight saving changes (as the “local time” stored on the RTC is an hour wrong over the transition period) which is the reason why traditionally Linux will store it as UTC.


Thanks Oliver for pointing out this issue.

An alternative is to leave Linux to its default (UTC), and make Windows read/store time in UTC instead of Local, as follows:





This thread was created for running Piaware on Raspbian PIXEL x86 LIVE image with Persistance, burned on a USB Flash stick. This image is NOT installable on Hard Drive without some additional workaround.

The Live image with persistance was released just before Christmas in Dec 2016, and is downloadable from here:
Web Page:

Download Link:


Subsequently in June 2017, raspberrypi foundation has released an installable image of PIXEL x86. If someone has an old Windows Laptop and want to utilize it by installing Raspbian Pixel x86 on HARD DRIVE, he can download the image, burn it on CD/DVD, and from CD/DVD install it on Hard Drive. It can also be installed on a USB Flash stick.

Web Page (scroll to bottom to heading “ONE MORE THING…”)

Download link:


When I enable password authentication for ssh I lose my WiFi connection to the computer.