Reset/change receiver


is it possible to change the type of receiver?
I need to change Site 15298 from SBS-3 back to Piaware…for MLAT.
Is this possible :question:

Is 15928 a real SBS-3? The data we see is a little confusing, it looks like data from multiple receivers.

Generally you can just start up piaware and it will create a new site as needed. For mlat, you are going to need one site per location/receiver anyway.

Not anymore. :slight_smile: Piaware only.

Piaware runs, but unfortunately is there no new site.

Have you claimed the receiver at ?
I see site 16707 on your stats page too, it’s not that one?

16707 is the second.
But the is also a Piaware running at 15298.
But the Statspage still shows SBS-3 :confused:

Can you explain your piaware setup, please?
It is reporting a bad MAC address which is probably why the site does not appear.

It looks like something unusual given the interface names / uname info it’s reporting; I guess that the setup has confused piaware’s MAC-detection, I’ll need some details so I can fix it.

Also, note the mlat does not work with a combined feed (based on your stats I think that’s what you have there…), you’ll need to separate out the feeds so each receiver feeds to a different piaware instance.

If MLAT does not work, then I turn back to the old format. (SBS-3)
Thanks for the help. :slight_smile:

If you are feeding a combined feed via SBS-3 but it is not a real SBS-3 (I guess you are using modesmixer?) … that’s really not a supported way of doing it and I can’t guarantee that the SBS feed mechanism will remain there forever, it has a number of problems that mean we really want to stop using it when possible.

It would be better if you can feed the combined feed via piaware (even if mlat is disabled).

Yes, I use modesmixer. Great software. :slight_smile:
It was the only way for me to push the planes to the FA-Server. Because piaware won’t run on my server. :confused:
Now it is running but there is still the problem with the Mac.
I had the Mac once entered manually. Somewhere in the settings…In a tcl file. Maybe it works again.
I just do not remember where exactly I made the change.

Probably in get_mac_address_or_quit in /usr/lib/piaware/helpers.tcl

If you can send me the output of:

$ cat /sys/class/net/eth0/address
$ ifconfig

then I can probably fix this in piaware itself for the future.


there is no eth0. Only venet0 and venet0:0

venet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr: P-t-P: Bcast: Mask:
inet6 addr: 2a00:f48:****:1::3554:da45/128 Scope:Global
RX packets:3719116 errors:0 dropped:0 overruns:0 frame:0
TX packets:5651243 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1085085535 (1.0 GiB) TX bytes:5015578175 (4.6 GiB)

As you can see, the HW-Address is empty.

Unfortunately I can not find get_mac_address_or_quit in helpers.tcl.

maybe this will help … /usr/lib/fa_adept_packages/fa_adept_client.tcl

As you can see, the HW-Address is empty.

Yeah, that’s going to make it a bit trickier! Do none of the interfaces on your system have a hardware address?

We do need to support this sort of setup, it is just hard to change without disrupting all the existing installs.

Unfortunately I can not find get_mac_address_or_quit in helpers.tcl.

My mistake. Try /usr/lib/fa_adept_packages/fa_adept_client.tcl.

Thx. I changed

set macFile /sys/class/net/eth0/address
set macFile /home/radar/famac

famac contains a fake-mac…let’s see if it works.

Edit: works now :slight_smile:

If it’s an OpenVZ installation then all of the NOARP interfaces are going to be blank addressed (all VENET’s). If it’s a system you can control, you may be able to use a VETH device which should generate a MAC…