FlightAware Discussions

Problems with update to 3.7.1

Don’t know what was changed in the update to 3.7.1, but I have 2 nodes, one upgraded from 3.5 to 3.7.1 okay but the other one was still running on 3.1.0.
The one that was running on 3.1.0 is now dead. I have remade the SD card numerous times with various versions of Raspberry pi software and then tried the various versions of PiAware, but now the Site 13211-KADS no longer communicates with FlightAware. Don’t know what the issue is. I’ve wasted too much time on it now, so I guess I’ll just let it stay off the air. Appears that Dump1090-fa doesn’t run but now the pi doesn’t even communicate with FlightAware, have no idea how to troubleshoot that.
The other node is working so I’ll let it go till it dies and then it can go off the air. Guess I didn’t need 2 nodes anyway.
In reading several posts on here others have been having same problems and I don’t have the time nor the knowledge to go digging around in the files on the raspberry pi to try to find the issue. If it was just a software issue, I would reload the SD card with known good working software but I think there is also issues with the software and I see no consistent issues discussed that might be causing the problem in the posts on this forum.

Hi Jasdel49,

It looks like you are installing PiAware via the package install on Site 13211. Have you installed dump1090-fa as well?

Please follow the steps found at https://flightaware.com/adsb/piaware/install if you’ve started with a clean Raspbian image.

Did you configure the feeder-id?

Otherwise the site get’s a random new feeder-id.
(For Beginners - How to Get Back Existing Station Number in A Fresh Install)

You can check the local logs for piaware and post them here if you want:

sudo journalctl -eu piaware | grep -v 'reported location\|--lat\|feeder ID'

(the grep part of the command will remove the feeder id and the exact location so you can post it here if you want)

If you want to look at the logs for dump1090-fa you can use this:

sudo journalctl --no-pager -u dump1090-fa 

[/quote]
wiedehopf:

Did you configure the feeder-id?

[/quote]
I gave it one more try. I reinstalled 3.5.0 since that worked on the other site. I went in then and configured the feeder-id as you suggested and that appears to have fixed it. I missed that step about configuring the feeder-id.
I will upgrade this to 3.7.1 when I get more time, maybe this weekend and I will use another SD card for the upgrade and I will configure the feeder-id this time.

Thanks a lot for your help.

1 Like

I got an email that I should update my PiAware from 3.6.3 to 3.7.1.
I followed the procedure in the email to update using the Configure screen on MyADS-B. It said it sent the message to update and restart.
However, it didn’t update. It did seem to crash the system so I rebooted and still on 3.6.3

Did you reset your browser? Ctrl F5 should refresh your browser screen to the latest version.

I’ve refreshed the browser (on several different machines) and still on 3.6.3

If the Pi is easily accessable, then cleanest option is to write to your microSD card the latest Piaware sd card image 3.7.1

http://piaware.flightcdn.com/piaware-sd-card-3.7.1.img.zip

Probably will end up doing that.
Thanks.

Your piaware seems updated according to your stats.
(separate component from dump1090-fa, that version is displayed in SkyView)

There should be a log about the update available.

I decided to try the automatic update again before reimaging.
Looks like it worked this time!
Thanks for your help.

There are two commands to be issued:
(1) Upgrade piaware
(2) Upgrade dump1090-fa.

If you upgrade piaware, it will upgrade only piaware, and not dump1090-fa.
as a result, your stats site will show your piaware version (3.7.1) and your Skyview map will show dump1090-fa version (3.6.3).
Give command to upgrade dump1090-fa also.
.
.

image

.

Give command to upgrade dump1090-fa also.

Thanks. I just did that. Hopefully it will go without problems.

Just an update. I’ve successfully updated to 3.7.1 thanks to your help.
I also note that I seem to have better reception after the update. My location is at Lake Tahoe which is in a basin at 6500 feet surrounded by 10,000+ feet mountains. Because of this, it’s hard to get long range reception. Since the update, I’ve noticed about 20% more long range sightings.

2 Likes

:+1: :+1: :+1:
Great

It may be that by default the piaware sd-card now uses AGC instead of 49 as a default gain setting.
Not sure about it though.

That may explain people are reporting better range.

Your guess is right.
Today morning I wrote Piaware sd card image, and checked default settings. Gain for both is “max”.

However this “max” in piaware.conf is translated to --gain -10 in files /etc/defaut/dump1090-fa and /etc/defaut/dump1090-fa, which is again translated to AGC in output of commands sudo systemctl status dump1090-fa and sudo systemctl status dump978-fa

pi@piaware:~ $ sudo piaware-config uat-receiver-type sdr

pi@piaware:~ $ sudo piaware-config  uat-sdr-device driver=rtlsdr,serial=00000978

pi@piaware:~ $ piaware-config -show rtlsdr-gain
max

pi@piaware:~ $ piaware-config -show uat-sdr-gain
max

It was using 49.6 before as a default, did it not?
Or rather didn’t pass a gain argument to the dump1090-fa process, which results in a gain of 49.6 i think.

Old default was -10, so there’s no change there.