Another 'why wont it work?!?!' thread...

I have a PI, I didn’t want to completely format my SD because of other ongoing projects using this PI simultaneously, so I found instructions online to go through and install everything needed one by one. Everything went to plan, no issues. Until I put the pi and the antenna back on the roof. It’s been up there about 6 hours, and I am still not seeing anything populating on the FlightAware site.

Here is what I am getting when I run ‘sudo piaware-status’

dump1090 is not running
faup1090 is not running
piaware is running
no program appears to be listening for connections on port 30005
faup1090 is NOT connected to port 30005
piaware is connected to FlightAware
got 'couldn't open socket: connection refused'
maybe dump1090 is NOT producing data on port 30005

Through my insane abilities in the areas of deductive reasoning, I am able to assume that my dump1090 is not running, and because it’s not running, it wouldn’t be producing data on port 30005. However, my linux skills are lacking far behind my reasoning skills, and here is where I am stuck.

I have tried to blacklist the driver, but I keep getting an error, the ‘kernel driver is active…’ and so on. I was under the impression that blacklisting the drivers would solve this?

Any help you guys can offer would be greatly appreciated!

Thank you.

Turns out my blacklist file, also had a ‘.save’ file which was screwing something up. I deleted it, rebooted, and now it’s tracking planes.

Thanks for the help guys!