Updated Pi, now it will not work?


#1

So I did an update via the web address, full update and rebooted.
When it came back online I got nothing, not connected to flightware, nothing running etc.
I have finally got to this stage:

pi@piaware ~ $ sudo piaware-status
dump1090 is not running.
faup1090 is not running.
piaware is running.
no program appears to be listening for connections on port 30005.
no program appears to be listening for connections on port 10001.
piaware is NOT connected to port 10001.
piaware is connected to FlightAware.
maybe dump1090 is producing data on port 10001.
maybe dump1090 is producing data on port 30005.

It shows I am connected to Flightware, but dump isn’t working, also if I try rtl_test -r it comes up with:

pi@piaware ~ $ rtl_test -t
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM

Kernel driver is active, or device is claimed by second instance of librtlsdr.
In the first case, please either detach or blacklist the kernel module
(dvb_usb_rtl28xxu), or enable automatic detaching at compile time.

usb_claim_interface error -6
Failed to open rtlsdr device #0.

Since the update nothing is now working, so assistance is required.

Thanks

Ps All was working fine before the update (which will teach me to not update this thing ever again)


#2

So after some more checking I can see data via ./view1090
Now I do not understand why piaware is NOT connected to port 10001?

Any ideas? restarting doesn’t do anything.


#3

No one?


#4

So starting dump1090 myself, all works!
Thought this was supposed to work as soon as pi rebooted?


#5

Does the file /etc/init.d/fadump1090.sh exist and is it executable?
That is where dump1090 will start from on reboot.
You should also make sure you’re running in run-level 2 (who -r will show that)

Good luck…


#6

Hi,

Installed everything yesterday and it just worked perfect via LAN cable.
Configured WLAN now it isn’t working anymore.

Tried to figure it out myself, but I’m very new to this.

But problems given are the same as above mentioned in this thread.
Checked everything possible for me.
Run level = 2
fadump1090.sh is there and so on.

Could some one please give me some help ?


#7

can you explain better your hardware and configuration? its importante for give yousome help


#8

As hardware I’m using a Raspberry Pi 2, Noelec RTL SDR dongle.
I installed the “PiAware on Raspbian Linux 1.20-1 ZIP” on a 16GB class 10 SD Card.
Followed the instructions mentioned and system was running correctly.

NOW, after I get rid of my LAN cable and installed a WIFI dongle I’m no langer able to connect to FlightAware.

Internet connection is tested and running.

When i give the “sudo piaware-status” command i get this result:

dump1090 is running
faup1090 is not running
piaware is running
dump1090 is listening for connections on port 30005
dump1090 is listening for connections on port 10001
piaware is NOT connected to port 10001
piaware is connected to FlightAware
got 'couldn’t open socket: connection timed out’
dump1090 is NOT producing data on port 30005
got 'couldn’t open socket: connection timed out’
dump1090 is NOT producing data on port 10001

I have allmost no knowledge from Linux or raspberry, so I need some help.


#9

@tiger213: Have you tried remote login (telnet)?


#10

What WIFI dongle are you using? How did you configure it? Can you connect to the internet while using WIFI?

Cheers!
LitterBug


#11

@Bidgee, I’m a noob, I don’t know what Telnet or remote login is.

@LitterBug, I’m using a Linksys Wlan dongle, I followed the instructions on the PiAware homepage who explained how to install wifi.
after installation Wifi is working perfect. I have access to the internet, and can even browse internet with my Raspberry pi.


#12

tiger213, it sounds like a whole new world is going to open up to you. I would recommend finding a good intro to the Unix world (the pi is running an offshoot of that). Check your local library or amazon. A couple of quick finds are 'The complete Idiots Guide to Unix" and “Unix for Dummies”. Don’t be put off by the names, they have a good bit of background info to get you up and running. Telnet is a way of connecting to a remote computer that goes back to, I think, 1968, and remote login (rlogin) and secure shell (sh) do similar. It’s learning a whole new language. Welcome to the chaos! :slight_smile:


#13

Ok, I did some quick reading on the www, and I installed putty on my laptop and established a connection to the raspberry.
But now I have putty running and up what should I do further ?

You must understand one thing. Plane spotting is my hobby not understanding unix.
I tought this would be easy going but now I’m really stuck.

I think I will stick to plane plotter and adsb scope on my laptop, this is working just perfect.


#14

Perhaps a wise move. A little knowledge of Unix is a slippery slope and can be addicting. Are you running a planeplotter ground station?
cheers :slight_smile:


#15

Yes, I’m running plane plotter ground station for a long time now. Setup was well documented and worked without any problems.

I tought I try PiAware with a second RTL USB dongle and a new antenna but I never tought that software setup was that difficult.
Strange enough when first setup with using LAN cable worked, problem started after WLAN setup. Lan cable is no alternative for me, I need WLAN.

So even when I will learn unix or linux that doesn’t say my problem whith raspberry is solved.


#16

Have you had the wlan operating yet so far? My config for wlan on my Pi consists of editing two files. Its fairly simple.
If that is your only roadblock then I think it can be overcome pretty easily.


#17

Yes, WLAN is working.