Problems with Nooelec R280T Dongle


#1

I have piaware running from the sd image. It is connected to flightaware but dump1090 is not running when I check sudo piaware-status. When I try to manually run dump1090 it says no RTLSDR devices found. Device is there when I run lsusb. I followed blacklisting instructions for kernel drivers on forums. Can anyone help?


#2

What happens if you try “rtl_test”?
What exactly is the output from “lsusb”?
Try “lsmod” and check if there’s nothing containing “rtl28xx”.


#3

Weird, I put the sd card and dongle in a different Pi 2(same model, just different one I had laying around) and it works perfect now. Now I’m really perplexed!


#4

Rebooted device and not working again, no hardware changes. WTF?


#5

…and lsmod gives this…


#6

So, I reinstalled fresh piaware image and it worked fine at first boot. All I did after that was expand sd card and change locale in raspi-config, and that broke it again. I think changing the locale may have broke it for some reason. Reimaging card now and will see if problem is reproducible.


#7

So worked with new image. I didn’t change anything except for user pi’s passwd. Rebooted device and it was broke. Didn’t even go into raspi-config.


#8

Sounds like you have faulty hardware.


#9

It’s up and running now and the dongle worked fine with Stratux so I don’t think it’s the dongle. Maybe a short in the Pi USB connector. Working now so I’ll leave it be!