FlightAware Discussions

What Have I Done?

I set up Piaware on a Raspberry Pi 4 and had it running without problems. The SDR was a NooElec Smart. I then replaced the NooElec with an RTL dongle but nothing worked. So I put the NooElec back but still nothing worked. I have subsequently flashed new SD cards and reinstalled Piaware several times. I had it running briefly yesterday but it stopped after a few minutes and now I can’t get it going again despite reinstalling everything. The Pi works fine if the SDR dongle is not connected, I can connect with it over wifi without problems and it is running. The problem comes when I connect the SDR as it locks the Pi and I can no longer connect to it. Starting the Pi with the SDR already inserted makes no difference. I have tried with a different NooElec Smart (I have two) and the same happens as it does when I replace the Pi 4 with the Pi 2 I used when I first set up PiAware - which worked at the time.

Has anyone any idea how inserting an RTL dongle could cause such problems as everything went wrong after I did this? Could it have somehow corrupted the firmware on the NooElecs?

This sound a bit like a dodgy PSU to me. Have you got another one you could try?

2 Likes

Thank you, yes I’ve tried another 3A supply and also a powered USB hub, but the same thing happens.

Is the Pi running hot? Could it be shutting down as a result?

1 Like

One other question - are you plugging the dongle into one of the USB 3 ports? I’m not certain but I think I read that some of them need to plugged into one of the USB 2 ports.

1 Like

Faulty USB ports on the Pi4 maybe.

Try plugging the powered hub into the USB while the RPi is supplied with another power supply.
If it keeps running try plugging the SDR into the hub.

1 Like

No, it’s not running hot, it doesn’t work even when started from cold.

I’ve tried both. It was working plugged into a USB3 port before things went pear-shaped after trying the RTL dongle.

I think you might be right and somehow the RTL dongle damaged the USB ports.

I’ve just tried it again with the original Pi 2 and have now got it running again (not sure why it didn’t yesterday) so the NooElec dongle is working - see attached image. It looks as if the Pi 4 has failed. As its only a week old I might try and get a free replacement. :slight_smile:

It’s more likely that all your power supplies you tried were insufficient.
I wouldn’t recommend running the Pi4 with anything but the Official RPi power supply for the RPi4.
Try using the powered hub so it powers the SDR while the Pi4 is powered by another power supply.

2 Likes

I have used the official power supply and the powered USB hub but the same thing happens. The Pi locks up when I insert the dongle. I might try and see if I can run something else off the USB hubs, even if only a card reader.

I’ve just turned the Pi 4 on with nothing attached and entered the command lsusb -t

This is the result but I don’t know if it is correct for a Pi 4.

pi@raspberrypi:~ lsusb -t /: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M /: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/1p, 480M |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M pi@raspberrypi:~

this is the result of that command on my Pi4B with nothing attached

pi@raspberrypi:~ $ lsusb -t
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
pi@raspberrypi:~ $ 

I have two RTL-SDR V3s but I’ve never used them on this one. They’re in use on Pi3s and I don’t want to unplug them at the moment.

I may try one of them later when there’s no traffic about.

I was actually going to put a bigger SD card in there as it is getting a bit full so I may do that tonight while I’m at it.

1 Like

seems to be something missing in your output compared to mine.

1 Like

For what it’s worth, I’ve stopped watching TV on my computer because my TV receiver dongle causes the computer to restart. Maybe a faulty dongle?

1 Like

I thought the dongle was faulty but I’ve now got it up and running with the Pi 2. This makes me think it is a hardware fault on the Pi 4 as reinstalling the OS and Pi-aware makes no difference.

Do any other USB devices, eg a memory stick, work or not work okay with the Pi 4 in the different ports? With the caveat that if it is faulty you could potentially damage the memory stick to test this.

If it’s just the combination of the SDR and Pi 4, and the SDR is working elsewhere and the Pi 4 is not exhibting problems with other USB devices, I’m inclined to think it’s a software problem causing it to lock up. Perhaps when you moved devices around initially there was a physical knock or a momentary power dip which glitched the software or OS in a particular way and re-imaging the SD card is worth a test.

1 Like

Thank you. I haven’t got around to checking the USB ports on the Pi 4 with an SD card yet. Hopefully I can have a look tomorrow - got distracted today by the good weather and a BBQ. :slight_smile: I’ve re-installed all the software several times so I don’t think that is the problem. There is a way to update the Pi firmware I believe but I’ve contacted the supplier and see what they come back with first. I’m happy to try other things but I don’t want to invalidate the warranty.

Edit: Just discovered I must already have the latest firmware as I’ve done the update and full-upgrade commands.I must engage brain before typing next time. Blame the BBQ. :slight_smile:

My RTL-SDR V3 seems to work fine in my Pi4. It was only running for half an hour or so because I wanted to get my devices back doing their normal jobs but I was able to do everything I would expect to do on it.

Seems maybe you got a dud?

1 Like