Troubleshooting Piaware


#1

Got my feed up yesterday and was doing good until about 1am this morning (stats page shows nothing received since then.) I rebooted system and used sudo piaware-status to verfiy everything is up, but nothing has shown up at all on dump1090 for the past few hours despite flights being up in area.

Is there a way to check on the rtl-dbs dongle from command line? It is brand new. NooElec R820T fed to external antenna

Thanks

EDIT: I removed the outdoor external antenna to rule it out and went back to the stock antenna that came with dongle. Still no signal (I am outdoors AT the airport and should be getting something). Tried running rtl_test and got this message:

Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN:00000001

Using device 0: Generic RTL2832U OEM
usb_claim_interface error -6
Failed to open rtlsdr device #0.


#2

finally got rtl_test working after using killall on piaware and dump1090… it says the dongle is communicating. I also hooked it up to my laptop and verified it works with GQRX.

tmp/piaware.out says 0 msgs are being received from dump1090. I tried running dump1090–raw and get nothing other than the gain and sample rate of tuner.


#3

Sounds like an antenna or connector problem. Do you actually see signals around 1090mhz with gqrx ?