Problems connecting my DVB-T receiver

Hello everybody,

i have a Raspberry Pi 3 and yesterday i installed PiAware-2.1.-5 from this page:

Everything was smoothly and installation finished without any errors. After that i did check my piaware status and got this:

pi@raspberrypi: sudo piaware-status
dump1090 is not running.
faup1090 is not running.
piaware is running.
no program appears to be listening for connections on port 30005.
faup1090 is NOT connected to port 30005.
piaware is connected to FlightAware.

After that i noted that my Zolid Mini DVB-T Stick is not being recognized by OS on system start (i found errors in dmesg list after boot). So i downloaded some drivers for this device. Again restarted my Pi and errors from dmesg disappeared, but piaware status didn’t change…
Later i found some information that probably i need to blacklist my DVB-T dongle drivers for the system, so piaware can use this dongle. But how then OS recognize this stick if i faced same issue even without correct drivers ?
Anyway, i tried to blacklist my drivers, but this didn’t help to resolve my case.
I tried also to find similar topic here or some detailed FAQ, but find nothing.

Can somebody guide me what is wrong and what actions should be done with my device ? I am not total Linux newbie, but this situation made me really confused. :frowning:

Appreciate any comments :unamused:

navigate to cd dump1090
and do that command: ./dump1090

whats happeans??

– unplug and plug again your dvb-t stick

– restart dump1090

– check your credentials to login in flightware

im sure one of this options solve your problem, let me know afther you try.


I’m not sure that that device is supported by librtlsdr at all; what’s the chipset? You need a RTL2832 + a R820T tuner.

Seems the chipset in a Zolid Mini DVB-T is ITE9135 - no good for our use.

Getting next error:
root@raspberrypi:/usr/bin# ./dump1090
No supported RTLSDR devices found.

In dmesg i have this:
root@raspberrypi:/home/pi# dmesg | grep error
6.301383] usb 1-1.2: Direct firmware load for dvb-usb-it9135-01.fw failed with error -2
6.301477] dvb_usb_af9035: probe of 1-1.2:1.0 failed with error -2

So looks like really my DVB-T receiver chipset is bad for this :frowning:

But where it is mentioned that only such type of chipset is supported ? Didn’t find this when i decided to buy pi for ADS-B station…

Will FlightAware Pro Stick USB ADS-B Receiver from FlightAware solve my problem ? I found this device on FlightAware guidance page:


Yeah i visited that page too. But how you understood that this device is not supported ?

If you went by the shopping list you should have a supported dongle. The FA prostick is fine.

If you bought something else you’d need to do a bit of research first. The underlying receiver software is dump1090, which uses librtlsdr. A partial list of supported dongles is here: It is not sufficient to just buy a random DVB-T dongle, only the RTL2832 chipset has the necessary SDR mode. The second thing is that you need a dongle that can tune to 1090MHz; that further reduces the list.

Thanks a lot, this topic can be closed now i guess :slight_smile:

By the way, another important moment. Is the FA 1090 MHz filter is necessary to use the FA stick ? Or can be only FA stick purchased ?

It depends on your local RF environment. If there are strong signals e.g. GSM cell towers nearby, then they can overload the dongle’s amplifier and drown out the ADS-B signals. In those situations, having a filter helps. If you don’t have strong signals then the filter will actually make things a little worse.