piaware Doesn't Recognize dump1090


#1

I am trying to take my current Raspbian Wheezy and get piaware running on it.

I followed the instructions on this page: http://flightaware.com/adsb/piaware/install

When I restarted the pi, there was no response on my ADS-B webpage. I typed “sudo piaware-status” and got this:

dump1090 is not running.
faup1090 is not running.
piaware is running.
no program appears to be listening for connections on port 30005.
no program appears to be listening for connections on port 10001.
piaware is NOT connected to port 10001.
piaware is connected to FlightAware.
got 'couldn’t open socket: connection refused’
maybe dump1090 is NOT producing data on port 30005.
got 'couldn’t open socket: connection refused’
maybe dump1090 is NOT producing data on port 10001.

When I got this message the first time, I created a .sh from this page: http://www.satsignal.eu/raspberry-pi/dump1090.html, and followed the instructions on the same page so that it will auto start.

I ran piaware status again after restart, and got the same result. I next typed “sudo /etc/init.d/dump1090.sh” and got “Error! dump1090 is already running!”

So, my guess is that piaware isn’t seeing dump1090 working or something. But, as a Linux newbie, that’s just my guess!

Does anyone have any ideas? Thank you very much for your help!


#2

run up dump1090 again, this time interactively with a --help parameter … you probably need to enable the outputs on the program.


#3

Here is the list of --help options for dump1090:

http://www.satsignal.eu/raspberry-pi/dump1090.html#parameters

Do you have a suggestion of what option might be good to use?

Thank you once again for your help!


#4

These are the ones of interest

–net-ro-port TCP raw output listen port (default: 30002)
–net-sbs-port TCP BaseStation output listen port (default: 30003)
–net-bo-port TCP Beast output listen port (default: 30005)

It does depend on the version of dump1090 you are running. The Malcolm Robb version needs a helper task fuap1090 that comes with PiAware that PiAware starts.

Many of us are using Dump1090-mutability - this has lots of enhancements and doesn’t need the helper.

ads-b-flight-tracking-f21/raspbian-ubuntu-packages-for-dump1090-mutability-available-t19619.html

someone else will probably give a better answer.


#5

I appreciate your help on this! Plus, I don’t think that anyone else wants to answer it, anyway. :smiley:

I will try using the parameters first to see if that works. Otherwise, I will try that other version of dump1090.

Thank you again for your help!


#6

The biggest problem is likely to be the version of dump1090 you are using,

The original version was Antirez github.com/antirez/dump1090 - development on this stopped some time ago.

Malcolm Robb too a fork of antirez code and brought it forward.

Others have taken the (Malcolm Robb) code and produced versions for doing special task

OLiver Jowett (obj here) has taken a fork of the Malcom Robb code and a fork of the Flight Aware code, merged them and is very actively taking the code forward as dump1090 mutability github.com/mutability/dump1090-tools.


#7

I gave up on the original dump1090 and installed and activated the mutability version.

That got me online again, but now I have a duplicate entry in the Memphis region:

http://flightaware.com/adsb/stats/user/jmilleratp

Try clicking on the active “John Miller” link, the one that says “Live.” When you do, you will find that the new listing is inaccessible. All you get is my original “John Miller” entry, with the original’s last active date, etc.

Is there anyway to correct this? I am guessing since I am using a different piaware setup, I am getting this duplicate.

My suggestion for a solution is to just have piaware only recognize one listing for each Flight Aware account. So, even if you are coming from a different piaware installation, different URL, etc., you would only have the one listing. That is, unless the original installation is still active and sending data.

Thank you again for your help! I appreciate it.


#8

FA use the MAC address of the Ethernet port on your Pi to identify the station.

Apparently there is a way to supply a fake MAC address in 1090 mutability (never done it, I’d check the DUMP1090-mutability config files for clues how)