Problems getting PiAware to work with dump1090


#1

I’ve read what appeared to be good threads on the topic, but they always seem to veer off topic.

Anyhoo, I have dump1090 running on the Rapsberry. Finally discerned that there were additional command line parameters to include. What I have gleaned is to run with this:

./dump1090 --interactive --gain 49 --net --net-ro-port 30005 --net-sbs-port 30003

Here’s some sample output:

ab6247 25000 459 34.089 -83.463 52 47 5 sec
a5106e 4308 10050 279 34.003 -83.935 222 550 0 sec
ac6aa9 N9BX 43000 420 33.951 -84.028 341 406 0 sec

The screen starts showing a few planes nearby. OK, so ran /etc/init.d/piaware start and then tail -f /tmp/piaware.out and get this:

04/07/2015 21:44:38 lost connection to faup1090, reconnecting…
04/07/2015 21:44:38 no ADS-B data program is serving on port 30005, next check in 60s
04/07/2015 21:45:38 ADS-B data program ‘dump1090’ is listening on port 30005, so far so good
04/07/2015 21:45:38 i see nothing serving on port 10001, starting faup1090…
04/07/2015 21:45:38 started faup1090 (process ID 7559)
04/07/2015 21:45:41 connecting to faup1090 on port 10001…
04/07/2015 21:45:41 piaware is connected to faup1090 on port 10001

04/07/2015 21:52:43 0 msgs recv’d from dump1090 via faup1090 (0 in last 5m); 0 msgs sent to FlightAware

Going to break out Wireshark and nail down who is supposed to be listening on what port. I wish the logs were a little less cryptic.

Thanks to anyone who can provide insight


#2

Are you running dump in background? Are you opening a screen session to start Piaware?


#3

I have dump1090 running in a window, yes.

When I check the status on piaware:

root@rp2:~# /etc/init.d/piaware status
piaware is running

So it’s running in the background. So I tail /tmp/piaware.out and we have:

root@rp2:~# tail -f /tmp/piaware.out
04/08/2015 01:58:37 no ADS-B data program is serving on port 30005, next check in 60s
04/08/2015 01:59:37 no ADS-B data program is serving on port 30005, next check in 60s
04/08/2015 02:00:37 no ADS-B data program is serving on port 30005, next check in 60s
04/08/2015 02:01:42 ADS-B data program ‘dump1090’ is listening on port 30005, so far so good
04/08/2015 02:01:42 i see nothing serving on port 10001, starting faup1090…
04/08/2015 02:01:42 started faup1090 (process ID 2567)
04/08/2015 02:01:45 connecting to faup1090 on port 10001…
04/08/2015 02:01:45 piaware is connected to faup1090 on port 10001
04/08/2015 02:02:37 seconds since last message or startup (2710) less than threshold for action (3600), waiting…
04/08/2015 02:03:07 0 msgs recv’d from dump1090 via faup1090 (0 in last 5m); 0 msgs sent to FlightAware

It seems to be happy, but no messages are being transmitted and it does a lot of “waiting”.

Shrugs.


#4

Everything seems to be listening that should be:

root@rp2:~# netstat --tcp -pn
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:6011 127.0.0.1:39256 ESTABLISHED 2568/1
**tcp 0 0 127.0.0.1:30005 127.0.0.1:46837 ESTABLISHED 2564/dump1090
**tcp 0 0 192.168.1.139:22 192.168.1.175:64212 ESTABLISHED 2543/0
tcp 0 148 192.168.1.139:22 192.168.1.175:64867 ESTABLISHED 2632/2
tcp 0 0 127.0.0.1:58693 127.0.0.1:10001 ESTABLISHED 2261/piaware
tcp 0 0 127.0.0.1:10001 127.0.0.1:58693 ESTABLISHED 2567/faup1090
tcp 0 0 127.0.0.1:46837 127.0.0.1:30005 ESTABLISHED 2567/faup1090
tcp 0 0 192.168.1.139:53512 70.42.6.203:1200 ESTABLISHED 2261/piaware

tcp 0 0 192.168.1.139:22 192.168.1.175:64630 ESTABLISHED 2568/1
tcp 0 0 127.0.0.1:39256 127.0.0.1:6011 ESTABLISHED 2601/wireshark

So what’s the secret command line parameter to dump1090 that I’m missing?


#5

All looks OK to me. You won’t want --interactive when running it as a daemon obviously, but otherwise there’s nothing obviously wrong.

If you attach a netcat to port 30005, do you get output?
If you attach a netcat to port 10001, do you get output?


#6

Got it working by switching to a different dump1090. I had read that any of them would work, and so was using antirez’s. Switched to one that has a different header line (includes Sqwk, Sig) and it started working. Who knew?

Here’s a recent snapshot:

Hex Mode Sqwk Flight Alt Spd Hdg Lat Long Sig Msgs Ti-

ADC932 S 7157 21975 11 77 0
A6D9BF S 11775 36 158 0
A8B848 S 3123 26825 34 548 0
ADFE78 S RCH 140 23900 12 220 0
A1584A S 9125 8 610 1
AA1EE5 S 28000 5 202 7
A42EFC S 7135 DAL2578 28050 15 998 0


#7

Ah, right, I missed that you were using --net-ro-port. Basically the problem is that faup1090 expects Beast-format output on port 30005. antirez’s original version can’t generate Beast-format output, it only generates the AVR format.


#8

Hello kef762,

When you mention, “Got it working by switching to a different dump1090”, which Dump1090 did you switch to and how did you uninstall antirez’s?

I’m having the same problem as you are describing.

Thanks,

Luke