Problem getting FlightAware Raspberry Pi software to boot

Hi, I’ve assembled the Raspberry Pi computer given the directions on FlightAware. It’s RPi 3.

I’m using Macs to write the mini SD card, per the instructions.

The system won’t boot from that card.

To check if it was that card and software, and not the newly purchased RPi, I downloaded Noobs from a RPi site, loaded the software onto another card and that software and card WILL boot the RPi (I connected it to an HDMI TV). Also, the radio receiver USB dongles status light will illuminate with the Noobs boot, but not with the FlightAware software.

I’m a nooby to all of this, though my computer experience goes back 40 years, so I have command line, etc. experience.

Any thoughts and suggestions would be appreciated.

Thanks in advance.

Jerry K

(If you want to PM me, K a s h i n s k i @

The piaware image will not work on an RPI3

You can install Jessie then add the add-ons manually and it works fine.


To walk through this, can I load the Noobs version onto the SD card, boot, and then go from there with the URL you sent me?

Or should I install another version onto the SD card first?

Appreciate the help.

Think I was just able to answer my own question.

Found Jesse here:

Doh! Jessie

It should, work from noobs, however, I have never used noobs.

If it complains about something not being installed the it is usually simple to install it.

Something like
sudo apt-get install programx
Where programx is the program or module you need installed.

There is also Joe’s “do it all in one go” script
It installs everything you need and adds some stats collection and other nice features.
It takes less than 20 minutes to setup.

Ensure you add your antenna location details to your FA webpage. It should be available in about an hour after you set it up. The antenna location is used to triangulate aircraft that don’t send position information. You can choose how accurately others can see your location, however, try to get it as accurate as possible for the device to work best. You can get the info from google maps and other mapping sites. Also from a GPS unit in a phone. Just be sure to convert it to the correct form.

Jon, thanks for the help.

I’m installing Jessie right now on the SD card, having deleted Noobs.

I’ll then install the FA software per the link you sent me.

I’ll let you know how it works out after all’s installed and (hopefully) up and running.

Thanks for the tip on setting the antenna location.

I’ve seen the location coordinates for our house on Google maps.

I just upgraded from Pi 2 to Pi 3 last night and used Noobs with no issues. :smiley:

Just got the RPi setup using: ads-b-flight-tracking-f21/ads-b-feeder-receiver-setup-scripts-t36532.html

Doing so took me back to my PC 1 days!!

Thank g*d for the internet, as unzipping the scripts, etc. were challenges.

The unit should be up and running, and I’m now waiting to see if FA’s getting the data.

One question, and I’m sure I’ll have more. Now that it’s set up, will I have to enter a log-in credential and password each time I restart the system? I have it running right now on the kitchen counter, hooked up to a TV for a monitor.

I want to put it in the attic and just let it run from there.

Second question I guess. Being new to this computing system, how do I get out of terminal and back to the GUI to set up the wireless (access point and password).

I really appreciate the hand holding and data from both of you!!


Re: login credentials on every restart. No, you don’t have to.

And to get back to GUI, type: startx

Edited to add: If you’re familiar with SSH, it will allow you to log in remotely to access your pi so you don’t have to bring it down from the attic.

Thanks. Appreciate both of your answering my dumb questions.

I went back into the cd ~/adsb-receiver/; ./ menu and found a check box for flightaware and also for software updates.

That’s happening as I type this.

When I enter startx, I receive the following message: -bash startx: command not found.

Any further suggestions would be greatly appreciated.


Hmm. You could try:

sudo raspi-config

Then enable boot to GUI. Then reboot. Are you just trying to setup wifi?

Yes, I’d like to set up wi-fi and more importantly, get FlightAware to recognize the feed. That still hasn’t happened.

I’m calling it for the night.

I’m wondering if the initial install and set up of the system got wonky.

I formatted another SD card and will go through the install and update process tomorrow on the other/new SD card install.

Appreciate the help!

I feel your pain. Spent a good amount of hours getting the Pi 3 up and running yesterday. Was up til midnight. Good luck, fingers crossed.

Thanks for the encouragement.

Makes me feel like less of an idiot!

If this is your first run with pi and FA, you may consider the standard install. Nice, clean and simple.

I’d tried that approach with Noobs, and it didn’t work.

I may try that again tomorrow too.

My biggest problem is the learning curve.

Have to figure out Raspberry Pi, and then figure out the FA software issues.

I think a good nights sleep will help!

cat /tmp/piaware.out for some fault finding messages.

Did you run sudo raspi-config to expand the partition space on the flash card?

Jon, thanks, yes, I expanded the partition space.

I’ll try the fault message command and report back.