Positions setting


#1

Hi everyone,

I added a new Raspberry with dump1090 and PiAware 3.5.1 to my account some weeks ago and have a problem with the position displayed on FlightAware (I already have two other Pis with identical settings at different locations which work without any problems): If I enter the coordinates in the “My ADS-B” section they are saved and it says “Location Source: User entered”, but after some minutes the Coordinates are set to (0, 0) and it says “Location Source: Receiver”. Can anyone tell me how to either switch off the transmission of the coordinates or set the correct coordinates in the Raspberry Pi?

Thanks a lot and greetings from Austria


#2

What OS image have you written to your microSD card?
Piaware 3.5.1, Raspbian, or something else?
(is it 3.5.1 or 3.5.3?)

What version of dump1090 you have?
dump1090-fa, or dump1090-mutability, or dump1090 Malcolm Robson?


#3

I have Raspian Jessie 8, dump1090 by Malcolm Robson and PiAware 3.5.1, running on a Raspberry Pi 3


#4

Did you click “Save” button after setting location on “My ADS-B” page?


#5

Yes I clicked “Safe”. After I clicked the save button the correct coordinates appeared in the overview, but only for a few minutes until they were overwritten by the wrong one by the system.


#6

I have not installed and used dump1090 Malcom Robb recently, but about 2 years ago when once I installed it, I created a file dump1090.sh to start it at boot.
sudo nano /etc/init.d/dump1090.sh

One of the lines in this file was:

PROG_ARGS="--interactive --net --net-ro-size 500 --net-ro-rate 5"

I dont know exactly what you have done, but If you also have created this file, add to above line following:
--lat xx.xxxx --lon yy.yyyy
so that the line becomes:

PROG_ARGS="--interactive --net --net-ro-size 500 --net-ro-rate 5 --lat xx.xxxx --lon yy.yyyy"

EDIT: Replace xx.xxxx and yy.yyyy by your actual latitude & longitude

Save the file, then reboot the Pi.


#7

I started dump1090 now with the extra arguments for the position, but it didn’t change anything, in the My ADS-B section it still is set to 0, 0


#8

is there a GPS connected ?


#9

No, there is no GPS connected


#10

@quis777 why don’t you simply use the flightaware sd-card image. it is super-easy to install/config and delivers perfect results as dump1090-fa is way better than the old malcomrob flavor …


#11

I don’t use the sd-card image because I also use my Pi for other stuff than feeding, therefore I need/want the Raspbian. But I changed to dump1090-fa now, which didn’t change anything, the same problem still persists.


#12

the location setting is probably more a piaware thing - i’d try to uninstall piaware and then reinstall 3.5.3


#13

Seems you hit bull’s eye.

sudo dpkg --purge piaware
wget http://flightaware.com/adsb/piaware/files/packages/pool/piaware/p/piaware-support/piaware-repository_3.5.3_all.deb
sudo dpkg -i piaware-repository_3.5.3_all.deb
sudo apt-get update
sudo apt-get install piaware

#14

After sudo dpkg --purge piaware command, all configuration will also be purged, including Unique feeder identifier UUID.

  1. If you dont want to retain existing station number “SITE 67827”, then click this link while logged-in to your FA account and you will get a new Station number: http://flightaware.com/adsb/piaware/claim

  2. If you want to retain existing “SITE 67827”, then go to https://flightaware.com/adsb/stats/user/quis777#stats-67827 and note down Unique Identifier (see screenshot below). Then give following command

    sudo piaware-config feeder-id xxxxxxxx-xxxx-xxxx-xxxxxxxxxxxx
    
    sudo systemctl restart piaware
    

    (Replace xxxxxxxx-xxxx-xxxx-xxxxxxxxxxxx by “Unique Identifier” from your stats page).

.


#15

That helped, now the locations stays the one I enter!
Thank you so much!