New to Flight Aware and tracking > My map is not correct...


#1

Hi there,

I am new to this forum and to Flight Tracking.

I have build my “own” ground station by following the great instruction given here under build your own FlightAware PiAware ADS-B Ground Station.

I am sure I have done something wrong, but I am not sure what.

My problem is that when I access the “map” using the IP address of my box 192.168.nnn.nnn:8080, where I say a few airplanes, but the map I am looking at is for sure not where I am located.

I did a ‘sudo piaware status’ with the result:

dump1090 is running.
faup1090 is not running.
piaware is running.
dump1090 is listening for connections on port 30005.
dump1090 is listening for connections on port 10001.
piaware is connected to port 10001.
piaware is connected to FlightAware.
dump1090 is producing data on port 10001.
dump1090 is producing data on port 30005.

I assume this is right?

I have entered the time zone I am in, but that don’t help much - I assume - related to the location - or?

How do I assure my location is correct as I don’t have a GPS receiver connected to the box.

Really appreciate your help as I am exited to get the here to work.

Cheers Steen


#2

Hi Steen,

Welcome. I too am quite new at all this. The map in dump1090 that you are viewing @ localhost:8080 can be altered by issuing the following command on your Pi. I login via SSH to do this stuff.


sudo vi /usr/share/dump1090/public_html/config.js

Once you are in the file go to insert mode by typing the letter i
You will know you are in insert mode as the bottom left corner of the editor will say “–INSERT–”

Scroll down and change the values 99.0 and -99.0:


// -- Map settings ----------------------------------------
// The Latitude and Longitude in decimal format
CONST_CENTERLAT = 99.0;
CONST_CENTERLON = -99.0;


Enter the coordinates for your location.

Scroll down further and change the values 99.9999 and -99.99999 as well:



// -- Site Settings ---------------------------------------
SiteShow    = true; // true or false
// The Latitude and Longitude in decimal format
SiteLat     = 99.99999;
SiteLon     = -99.99999;

SiteCircles = true; // true or false (Only shown if SiteShow is true)
// In nautical miles or km (depending settings value 'Metric')
SiteCirclesDistances = new Array(20,40,60,80);


SiteShow = true will mark your coordinates on the map with a marker.

SiteCircles = true will show range circles based on your location specified by the distances in SiteCirclesDistances. The example above has the circles spread apart by 20 nautical miles.

Once you are done you can hit the escape key and type wq! and hit enter. That will Write and Quit the editor. Refresh your webpage and the changes will be current.

Not sure how familiar you are with vi and linux commands so I tried to make this as simple as possible.

Good luck.


#3

The piaware status you posted looks normal.


#4

Steen, there is a known issue with the piaware reporting your location on the map. FA is working on the issue, but in the meantime, your apparent location can change. My primary feeder is stable, but one Pi ‘wanders’ and currently thinks it is about 25 mi E.


#5

Fixed…my location is now the correct one.
Not many airplanes in my area, but i have tracked some 5 planes over the past two hours.
Cheers Steen


#6

Hey joelwiley!
Thanks, I was located in Serbia, but actually I am currently in Venezuela ;o)
Fixed it by using my GPS for the car to get the right coordinates and then updated under my ADS-B Feeder Statistics.
And yes, even with the correct coordinates my locations somewhat off.

Happy Tracking holidays…

Steen


#7

Hi albanese19,

Thanks so much!

Cheers Steen


#8

Hello albanese19

I have been playing with your instructions here and keep running into an error in the saving routine. I have no issue with any point up to ‘hit escape and type wq! and press enter’

nothing happens when type wq!. However, when i type wq1, the screen displays ‘recording’ at the bottom and then freezes. I have left it up to one hour and still nothing happens. I can reboot and the pi and start the routine over again. a swf file has been created and i have chosen both ‘delete the swf file’ and ‘edit swf file’ and still run into the same issue when trying to write the file.

any ideas what I am doing incorrectly?

Thank you
Henry

The real Heisenberg


#9

You must type a colon before that sequence. i.e. press ‘:’ then type “wq!” and hit enter.


#10

Thanks toverfield. Looks like I had a typo and omitted the colon!

Pleased to meet your acquaintance “real” Heisenberg! :laughing: