FlightAware Discussions

Port 8080 not working

Newbie here. I installed Piaware and dump1090 on my RPi3 and it connects andsendsdata. However when i navigate to “IPaddress”:8080 I get an “unable to connect error”.

Any clues

Regards Gordo

I’m sorry for asking this: What IP address did you type in? Or did you literally type in what you wrote?

It should look something like this:
http://192.168.2.78:8080

You can also just click the link on your FA stats page:
Screenshot%20from%202019-01-04%2009-35-31

on your stats page (https://flightaware.com/adsb/stats/user/gaudough)

Some routers also isolate the wireless from the wired portion of the local network.
In that case you will have to change that setting in your router.
How are your computer and your RPi3 connected to your network?

So it was an add-on installation?
Tthen you should look at: <IP_of_Pi>/dump1090.php

The port 8080 works only for Piaware SD card installation.

Blockquote
The port 8080 works only for Piaware SD card installation.

That can’t be quite right. Port 8080 works for me on my add-on installations.

Yep that doesnt work, connected via ethernet cable to the same router

Tried that, no good.

What else are you using the RPi for? Maybe something else is interfering.

Please show the output of these two commands:

sudo journalctl -u lighttpd -n50 --no-pager
ls /etc/lighttpd/conf-enabled

Do not know about the add-on installation via apt, but at least that is the correct link to skyview if you use the adsbreceiver scripts

wiedhopf you nailed it. I am running motion for a webcam I have and it uses port 8097, when I ran the journalctl command it came back and told me that it couldnt open the port as it was already in use. I changed the port motion uses and bingo it works.
I changed the port motion is using to 9097… so why did 8097 interfere with 8080.

thanks again

Gordon

Does not make sense but glad that you got it fixed, happy tracking.

I think motion uses two ports, stream_port and webcontrol_port. The latter usually listens on 8080.

1 Like