FlightAware Discussions

Http:// Not loading

Hi - I have PiAware running and it is feeding flightaware nicely, however when I go to my local IP:8080 I get nothing. I have run ‘netstat -an |grep 8080’ on my raspberry Pi and the Pi is NOT listening on that port. I run fr24feed on the same pi and it works fine.

Is there a config file or some setting I need to change to make it work?

What image did you start from?
What modifications did you make?

1 Like

No modifications at all.

Image is piaware version 3.8.1

One of these is not correct.

Port 8080 is provided by lighttpd on an unmodified PiAware sdcard image. You’ll need to investigate why it’s not running correctly on your system (look at journalctl -u lighttpd as a start)

OK I changed the conf file now it is listening on port 8080 but going to that page just gives “403 forbidden”.

I don’t think anyone will be able to help you with this unless you are clear about what software you are running and what changes you have made.

Maybe try an unmodified PiAware sdcard image on a spare sdcard and check that it works OK as a starting point.


Normally caused by wrong permissions set manually.

As this seem to become more and more messed up, i would follow suggestion of @obj and start over with rebuilding the SDCard

It is a fresh install - the only thing changed is the conf file changed to listen on port 8080.

And this obviously caused the mess. A fresh install does not show this behavior. I tried it more than once

The standard PiAware sdcard image does not require any configuration changes to listen on port 8080, so I still don’t know what you started from and what you changed.

HI I can tell you exactly how I installed it according to the instructions on the flightaware site. I installed piaware only as I already run fr24feed. These are the exact instructions I followed:

Download and install the PiAware repository package, which tells your Pi’s package manager (apt) how to find FlightAware’s software packages in addition to the packages provided by Raspbian.

For Raspberry Pis running on Raspbian Buster OS , execute the following commands from the command line:

wget https://flightaware.com/adsb/piaware/files/packages/pool/piaware/p/piaware-support/piaware-repository_3.8.1_all.deb
sudo dpkg -i piaware-repository_3.8.1_all.deb

For Raspberry Pis running on Raspbian Stretch OS , click here

This will download and install PiAware and required dependencies on your Raspberry Pi.

sudo apt-get update
sudo apt-get install piaware

This will enable automatic and manual (web-based, via your request) PiAware software updates. These updates are disabled by default. To leave updates disabled, skip this step.

sudo piaware-config allow-auto-updates yes
sudo piaware-config allow-manual-updates yes

Well that doesn’t work as fr24feed doesn’t provide data on port 30005.

Also dump1090-fa is the package which provides the interface on port 8080.

You can use this

It will reconfigure fr24feed to use the data from dump1090-fa (as in contrast to fr24feed provides data on localhost ports)

Alternatively you could also use this: https://github.com/wiedehopf/adsb-scripts/wiki/Automatic-installation-for-readsb
Different interface compared to dump1090-fa, otherwise pretty much the same.

1 Like

I also suggest that is better to install fresh the piaware package (that includes the dump1090-fa decoder) and after that install the fr24feed.
The process is described here or on fr24 forums.

Or use Widenhopf package if you like. I use many of his Github creations.

That sentence really confuses the matter.
dump1090-fa is NOT a feed client, it’s a decoder.

1 Like

So you are not using the Piaware image we are all talking about. That makes the difference.
Trying to use the packages on a FR24 image will not work as described by @wiedehopf

Cut him a little slack.

It appears he started yesterday and misunderstood what image means.

I’m sure that the collective wisdom here will sort it out in the usual friendly and helpful manner.



Noted and corrected.

FR24 image is Raspbian Buster with dump1090-mutability and fr24feed pre-installed. Using piaware package on any debian/raspbian based image works fine, but you may not get map at 8080, and the radio status page of piaware sd card image will not be there.

The map is available at

1 Like

Which is the long version of my “will not work” in relation to what the Thread opener wants to do


Click on that and let us know what you’re getting.