FlightAware Discussions

PiAware Live Data View Will Not Load

I did a fresh install of PiAware on a fresh install of Jessie a couple of nights ago. Went through the whole process step by step. In about an hour I had my feed up and running. Once it was “claimed” I could load my local ip 192.168xxx.xxx:8080 and view my live data. I left that up and running for two days without a problem. Last night, My Pro Stick Plus came in, so I shut down, swapped my old SDR for the new Pro Stick and restarted. Everything seemed to be working, even FlightAware detected it. However, I couldn’t get the local 8080 view to load. After an hour, I noticed my new receiver had not seen a single aircraft. So I shut down, swapped my old SDR in and restarted. Came right up and within a few minutes I had an aircraft reported. However, I still could not bring up the 8080 feed locally. Restarted a few times and still the same. I have it running now with my older SDR and I can see data is getting fed, but still cannot get the local 8080 feed to load.

Has anyone else seen this?

Thanks!
Jason

Jason,

Check your webpage to see if the RPIs IP address has changed.
flightaware.com/adsb/stats/user/KE4NYV

Jon, I forgot to mention that I have checked that several times. I can ping the local IP. Also, I found where you modify the “webserver” HTML file if you just go to the IP without :8080 port added and that page loads fine. So I have narrowed it down to something being wrong with the PiAware side.

Thanks,
Jason

Did you use the piaware sdcard image or install by hand? If installing by hand, what dump1090 did you use and how did you arrange for it to serve data on port 8080?

I guess you could call it installed by hand. I started with a fresh image of Jessie loaded to my SD card, then I went through the steps here to load PiAware:

flightaware.com/adsb/piaware/install

I never saw any links for a premade image, so I didn’t think one existed. As I said before, the first night I had it running, going to port :8080 on the local IP worked without a problem. The problem seemed to happen after I tried using the Pro Stick.

No matter how many times I restart or verify the correct local IP, I can’t get 8080 to show, however I can get the test HTML file to show when leaving off the port 8080, so I know I’m getting to the Pi through the browser.

Thanks,
Jason

See flightaware.com/adsb/piaware/build for the image-based install.

It’s hard to diagnose your system without knowing exactly what you installed.
Perhaps you installed a webserver that competes for ports with lighttpd?
Does going to /dump1090-fa/ on port 80 work?

Ha! Adding /dump1090-fa/ to the end of the local IP worked!

https://dl.dropboxusercontent.com/u/3565228/piaware/PiAware-Dump1090-FA.jpg

Just for reference, here is the output from a “sudo piaware-status” command:

https://dl.dropboxusercontent.com/u/3565228/piaware/PiAware-Status.jpg

I’m still not sure why :8080 stopped working.

Hi Guys - now my recently working piaware live flight data wont connect.
Clicking on live flight data says
"This site can’t be reached
xxx.yyy.zzz.79 refused to connect.
Search Google for xxx yyy 8080
ERR_CONNECTION_REFUSED"
I replaced my IP with xxx yyy zzz btw.

I tried xxx.yyy.zzz.79/dump1090-fa and I get 404 not found error.

I have a uSD card with latest updates but scratching my head why it stopped working all of a sudden - I am live and dumping data to flightaware no issues.

Any ideas please?

I had the same problem, but going to http://192.168.1.90/dump1090-fa/ made it work. Don’t know why the address changed. Must have been in an update.