FlightAware Discussions

PiAware Skyview timing out

I followed the instructions on how to install the software using https://flightaware.com/adsb/piaware/build

I installed PiAware on Raspbian Linux 3.6.3 ZIP and got the device to connect to flightaware.com and report information.

When I try to use the Web Interface: PiAware Skyview (requires local network connection) it times out

How do I enable the web server and Skyview application?

It is enabled by default when you are using the sd-card image or even when you install the packages.

Did you install anything else on the Raspberry Pi?

There have been cases where the router does not allow traffic between the wireless LAN and cabled LAN.
Do you have the pi in a guest Wifi network by any chance?

You can try pinging the pi:

ping 192.168.50.118

(Also works in windows command prompt)

If that fails then you are not really in the same network as the Raspberry Pi and maybe need to check your router.

The only thing I installed what the PiAware on Raspbian Linux 3.6.3 ZIP.

I edited the configuration file to turn on the WiFi interface. I did not make any other changes or load any other software.

The device is on the same LAN segment 192.168.50.xxx as the other computers. It does not respond to PINGs.

I’ve tested it on both the WiFi and Wired LAN.

Do I need to install additional software to get this to work?

If it is not responding to pings then that means your router is configured to isolate the device somehow.

To really test on Ethernet you would need to remove the WiFi and just try Ethernet as having both at the same time has its own problems.

No it is a network problem, not a software problem.

Did you set up a static IP in the configuration file? In that case maybe you got something wrong there, could you post it?

Otherwise check your router settings for something called wireless isolation.

You were correct. The PiAware was on the guest network. I disabled WiFi and connected it to the Wired Network and was able to reach it.

It appears that the WiFi must be disabled in order to let the wired LAN route properly.

Thank you!

No problem.
Just put it on the non-guest WiFi then there should be no problems even with WiFi.