Having trouble connecting piaware and flightaware

I have built and successfully booted into the piaware iso. I ran sudo piaware-status and it says that everything is working. I just cannot get it to connect to flightaware. Both devices are connected to the same wireless network and I have tried wired as well, they were both connected to the same switch. Can anybody help me here?

You might need to claim your Site.


try command: route and command: ifconfig

Between them, you will be able to see if there is a conflict or problem in ip addressing.

I ran both of those commands and I am not sure what I’m looking at. What would hint that there is a conflict?

Update, I have entered the address of my piaware device into the search bar on my main computer and it shows a map in my location with a few planes flying around. It seems to only be a problem between myself and flightaware. Can anybody provide some suggestions here?

The “route” command should show you something like “default” route and your router address or name under “gateway” . The fact you can see the dump1090 map means your Pi is connected to your home network OK.

This doesn’t test getting outside your home network though.

On the Pi run “ping flightaware.com” without the quotes of course. Use ctl-c to stop the command. You should see something like:
64 bytes from webfarm.flightaware.com ( icmp_seq=3 ttl=44 time=65.4 ms
64 bytes from webfarm.flightaware.com ( icmp_seq=4 ttl=44 time=67.8 ms
64 bytes from webfarm.flightaware.com ( icmp_seq=5 ttl=44 time=66.4 ms
64 bytes from webfarm.flightaware.com ( icmp_seq=6 ttl=44 time=67.0 ms

The actual numbers may be different but the response should be in this format.

This tests to see if your Pi can get out onto the Internet and over to FA.
If you see and error about “unreachable” then there is a problem getting through your router from the Pi.

Thank you for replying, I am quite desperate at this point. I am successfully able to ping flightaware, I get no errors. What does this mean?

That’s a good sign! Your Pi can get out to the external internet.

Next I might try looking at the piaware log file. On the Pi enter the command “cat /tmp/piaware.out” (no quotes)
You should get a bunch of messages showing the status of the connections to FA. Some messages will have “mlat” after the date/time. Those are the status of MLAT processing. Others will simply say “nnnnn msgs recv’d from dump1090 (nnn in last 5m); nnnnn msgs sent to Flightaware”
These are repeated every 5 minutes.

If these indicate messages being sent to FA, then the Pi would appear to be communicating correctly I think.

Hope this helps,

I ran that and I am receiving messages from dump 1090, but I am sending 0 messages to flightaware. Near the top of my log it says that it was connecting to flight aware and got “Couldnt open socket, no such device or address”. Can you tell anything by this?

OK, that’s the problem, so you’ve made progress. Off the top of my head, I don’t know how to solve it though. I’d try to restart piaware and take another look at the /tmp/piaware.out to see any startup errors.

sudo service piaware restart
cat /tmp/piaware.out

I have to go out now. Perhaps if you post the messages from piaware.out after the restart, someone else will chime in. You can X out your lat/long if it shows up in the log and you are concerned about privacy.

Okay thanks for your help. I have my log here if anybody is willing to help out.

12/29/2015 16:46:20 ****************************************************
12/29/2015 16:46:20 piaware version 2.1-3 is running, process ID 2176
12/29/2015 16:46:20 your system info is: Linux piaware 4.1.7-v7+ #817 SMP PREEMPT Sat Sep 19 15:32:00 BST 2015 armv7l GNU/Linux
12/29/2015 16:46:20 connecting to FlightAware piaware.flightaware.com/1200
12/29/2015 16:46:20 got ‘couldn’t open socket: no such device or address (No address associated with hostname)’ to adept server at piaware.flightaware.com/1200, will try again soon…
12/29/2015 16:46:20 ADS-B data program ‘dump1090’ is listening on port 30005, so far so good
12/29/2015 16:46:20 Starting faup1090: /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --stdout
12/29/2015 16:46:20 Started faup1090 (pid 2329) to connect to dump1090
12/29/2015 16:47:02 0 msgs recv’d from dump1090; 0 msgs sent to FlightAware