PiAware and PlanePlotter

Today, I could not connect with FlightAware’s server. I checked my MAC Address, my IP adress and everything seemed fine but, still no connection. My Pi was receiving signals as shown on my dump1090 screen but they were not being transmitted to FA.

I had been using PlanePlotter with a NooElec dongle before installing my Raspberry Pi 3 with a Pro Stick and yesterday, I read about using PiAware to transmit data to PlanePlotter. I did that and it worked fine until last night.

I’ve been losing, for quite some time now, my internet signal every night because of my ISP’s technical problems (I’m in Venezuela) so I turn my Pi off when I lose the signal.

This morning, I turned my Pi ON and activated my PlanePlotter but, neither of them worked. The Pi was receiving signals but was not connecting with FlightAware nor was PlanePlotter connecting with the server.

I rebooted my Pi and nothing happened, stopped PlanePlotter, rebooted my Pi again and then it connected with FA.

Any ideas why this happened?, can I run PlanePlotter and get the signal from my Pi while connected to FA?, help is appreciated.

Thank you all.

No idea about PP, you should ask on their forums.

What does piaware-status or the top-level web status page say when piaware is having problems?
What does /var/log/piaware.log say?

Did your ISP change you IP addresses?

obj: The only thing that I could think of was PlanePlotter, there was nothing wrong with my Pi, it was receiving signals and showing them on my dump1090 screen but it did not communicate until I stopped PlanePlotter and rebooted my Pi.

joelwiley: Nothing changed as far as my internal IP and/or MAC Addresses. When the external IP changes, FlightAware automatically picks it.

Ever since I stopped Planeplotter it has been working fine.

Thanks to both of you.

There is a 9 character authorization code in you coaa.h file. If you plug it in to this url it will return your stats if ppup1090 is running.