FlightAware Discussions

PiAware 6.0 Status Page

Howdy all, I have just recently upgraded to the PiAware 6.0 software package and have discovered that when I access my status page it no longer displays the radio status or the links to navigate to the individual SkyAware pages and UAT pages. I am wondering if this is no longer available in 6.0, which would be a horrible feature to lose. Or if there is a setting I must enable or if I must travel to a different URL now to access this function.

Could someone please point me in the right direction?

Someone posted yesterday with the same problem.
See:

Try clearing your cache? Or failing that try rebooting the Pi.

Do you see any errors in the browser devtools? (Not sure how to get to that on a mobile browser)

(I’m unable to reproduce this problem - the status page should look much as it did in 5.0)

Copy-paste following script in terminal:

sudo bash -c "$(wget -O - https://raw.githubusercontent.com/abcd567a/piaware-ubuntu20-amd64/master/install-piaware-web.sh)"

This will reinstall the Piawareweb page.
When needed any dependencies will be corrected as well and when the installation is done it will state it in the terminal. after that you should be able to view the page.

2 Likes

@tomvdhorst i have tried that very command more than once and despite rebooting the device and rerunning the command I still get the same almost blank status page. Which does not show the health of my two radios or the state of the PiAware components. Simply the title and nothing else despite a successful install each time which directs me to my PiAware IP address to view the page. So I am at a loss as to where to go next.

I stand corrected, it appears to work on a chrome browser but not safari. And that is a major problem as all iPhone default browsers are safari.

Try clearing the cache on your Safari browsers :wink:

I could not reproduce this on desktop safari 14.1.12 (16611.3.10.1.6)

Unfortunately I don’t have an iphone to test mobile safari on.

Status page looks OK on my iphone running latest OS which should be using Safari 14.

What iOS are you running?

If you can reproduce on a Safari Web browser, check the console logs by going to Develop → Check Web Inspector and selecting Console. You may need to enable the “Show Develop in the menu bar” option in Preferences → Advanced if it’s not there already.

I will have to try that.

I am running IOS version 14.7.1 on an iPhone 12 Pro Max. So I’m not sure how you have 14.1.12 and I have 14.7.1. But I will try using the web inspector.

Is there perhaps an advanced experimental feature I don’t have enabled?

Obj was referring to his safari web browser. But looks like you are on the latest iOS version.

If you have a Mac, you could hook up the phone to it to view the console https://www.browserstack.com/guide/how-to-debug-on-iphone

Again, I stand corrected and feel stupid. But after I clears the cache for the 5th time and restarted my phone for the 6th time. It now displays the status page correctly…

I have no idea why this round of clearing the cache worked when it didn’t before. I changed nothing on the feeder and changed no settings on my iPhone besides clearing the cache again and restarting the phone. But it is now working.

I will still go and use the web inspector and check the logs to see why this round was different but the issue is now resolved.

2 Likes

@eric1tran oh i understand.

Thank you.

No worries :slight_smile: Glad it’s working now. Let us know if you find anything odd.

1 Like

Thank you @eric1tran!

Will do!