FlightAware Discussions

PiAware 3.8 Zip file reports as corrupt

Hi
Have tried to download latest PiAware software for RaspberryPi.
When I use Etcher to flash an 8GB sdhc card it fails.
Both WinRar and 7z are reporting the file as corrupt (CRC).

regards

I just tried the download and the file comes down okay. If you have a MD5 checksum tool for Windows, check the downloaded file. It should have the name and checksum:

ca21cdb23bc691f4bb050122d2b022e9 piaware-sd-card-3.8.0.img.zip

If it doesn’t then it’s likely the file was downloaded badly or interrupted. Delete it and try again and confirm the name and checksum.

There’s a new tool you might want to try called Raspberry Pi Imager. I’ve ditched Etcher and use this now instead.

2 Likes

Hi
Tried again but winrar still reports the file as corrupt.

I’m using firefox browser and downloading this file from http://piaware.flightcdn.com/piaware-sd-card-3.8.0.img.zip
I used a couple MD5 checkers on this file.
They both report the checksum as:
04f99f22c6ef4ba16e05095b37f43040
which is different to the one you reported.
Going to try wget to see if any different.
regards

I can’t reproduce the corruption on a fresh download. The ca21cdb… md5sum mentioned above is the correct one.

I tried with the latest Firefox on Windows and get the same as I get on the Mac

C:\Users\Chris\Downloads>certutil -hashfile piaware-sd-card-3.8.0.img.zip MD5
MD5 hash of file piaware-sd-card-3.8.0.img.zip:
ca 21 cd b2 3b c6 91 f4 bb 05 01 22 d2 b0 22 e9
CertUtil: -hashfile command completed successfully.

Perhaps there’s an extension (or something unwanted) in your Firefox messing around with the download. There’s an option in Firefox to restart without them. 3 lines menu upper-right corner --> Help --> Restart with Add-ons Disabled. Wget as you say is also a good test.

I just downloaded as well, I get the same MD5 and I can unzip the image successfully.

feek@ShackiMac ~ % md5 /Users/feek/Downloads/piaware-sd-card-3.8.0.img.zip 
MD5 (/Users/feek/Downloads/piaware-sd-card-3.8.0.img.zip) = ca21cdb23bc691f4bb050122d2b022e9
feek@ShackiMac ~ % 

If you use Etcher or whatever it’s called these days, you can write the image without unzipping it but of course you have to get a good download first.

Thank you all for your help. Much appreciated.
I now have the file downloaded with the correct MD5 CRC.
I achieved this by using a different computer and a mobile phone hotspot.

I did try downloading with wget but am embarrassed to say I got a different CRC than I did with the other corrupt downloads using firefox.

Pure speculation, but I think the problem may have something to do with virus protection.
When I get some time next week I’ll temporarily turn virus protection off and re-test.

Anyway thanks again for the help. Not being able to get the zip file is now SOLVED.

It could indeed be that but it’s a poor show from whatever software would interfere like that. On the flip side it could theoretically be a virus or malware, trying to insert itself into images and code that you download. Worth doing a full scan and ensuring everything’s behaving as it should. It might be worth checking any other downloads you got too, in case they have been similarly affected.

@obj, perhaps the MD5 sum could be included next to the links on https://flightaware.com/adsb/piaware/build to help people check they have an intact download if needed.

Not related to this issue, but a similar unusual problem:
I can clone dump1090-fa source code on all types of distros on VM, but two days ago failed on NetBSD on VM:

SSL Certificate issue.

localhost# git clone https://github.com/flightaware/dump1090.git dump1090-fa
Cloning into 'dump1090-fa'...
fatal: unable to access 'https://github.com/flightaware/dump1090.git/': SSL certificate problem: unable to get local issuer certificate

Succeeded only after this workaround.

localhost# git config --global http.sslVerify false
localhost# git clone https://github.com/flightaware/dump1090.git dump1090-fa
localhost# git config --global http.sslVerify true

That’s a local problem with your root CA store.

1 Like