dump


#1

Can someone help me fix this error? We cannot get piaware or dump1090 to run.
We flashed the piaware image to the sdcard, but when we installed the card in the RPi, it wanted gave us a GUI and a list of operating systems to install. We chose raspbian, and then reinstalled dump1090 and piaware, and still it didn’t work. We reflashed the card from scratch, did all of that over again, the did an update and upgrade, then reinstalled piaware and dump1090, and still the same problem! I am lost! please help Thanks


#2

Perhaps your sdcard was not completely blank when you wrote the piaware image to it? If you had multiple partitions on it initially, then that might have written to it properly. Unless you’re particularly fond of that system image, I’d recommend starting over and completely erasing your sdcard and all partitions, then writing a fresh copy of the piaware image to it.


#3

The sccard was clean before install of the image. Three times I formatted it and removed the extra partitions that it creates when inserted into the Rpi. I am working on this for n175mc and I had none of these problems when installing mine.


#4

Why would it boot to an install screen (noobs?) every time I stuck the newly flashed card? I retried the flash multiple time on a cleanly partioned (one partition) and fat32 formatted sd card


#5

The image should boot up automatically without any need to interact with it at all. If it is prompting you at first boot then there is probably something wrong with how the image is being written to the sdcard.

What OS are you writing the image to the sdcard from?


#6

Window 7. I am going to try to flash the 1.14.3 flash that worked on my setup. Perhaps the 1.15.1 flash is corrupted. That’s the one thing I haven’t retried three times. The flash has always completed successfully, and it appears that it is set up properly in windows explorer


#7

Finally got it working by installing the 1.14.3 rather than the 1.15.1. Looks like that 1.15.1 that was downloaded was bad and opened noobs and an installation script rather than pia ware.


#8

okay thanks. we’re investigating now.


#9

Can you check the sha1 hash of the 1.15.1 image to make sure your download wasn’t corrupted?

SHA1 (raspbian-piaware-1.15-1.img.zip) = 9305adc4da5b278496b95cceeaa30292fac228b4
SHA1 (raspbian-piaware-1.15-1.img) = 27d8accae3616cf838ed85507812de5ee93b8758


#10

Can you please link to the SD card you purchased? We do not include noobs in our image, so if that’s on your SD card, it’s not from FlightAware.

You shouldn’t need to install our image onto a partition. Delete all partitions on the SD card and install the image directly onto the SD card.


#11

I’ll look it up and see what I can find out.
I can confirm I did flash the image on a wiped 8gb sd card with only one partition. As soon as we would put the card in the Rpi, it would repartition it. I’ll get back with sd card info also.


#12

Just to be sure, this afternoon I did a fresh download of “PiAware on Raspbian Linux 1.15-1 ZIP” on a Mac, copied it to a Micro SD card according to section 2 of the instructions at flightaware.com/adsb/piaware/build, and booted it up on a Model B+ with an RTL-SDR dongle and it is working.


10/18/2014 01:08:10 ****************************************************
10/18/2014 01:08:10 piaware version 1.15 is running, process ID 2075
...
10/18/2014 01:08:11 encrypted session established with FlightAware
...
10/18/2014 01:08:12 piaware received a message from the ADS-B source!
...
10/28/2014 01:15:49 piaware has successfully sent several msgs to FlightAware!
10/28/2014 01:15:49 7 msgs recv'd from dump1090 (4 in last 1m); 7 msgs sent to FlightAware
...
10/28/2014 01:20:49 71 msgs recv'd from dump1090 (64 in last 5m); 72 msgs sent to FlightAware



#13

I will be able to check on it tomorrow. Not sure where exactly he downloaded the image from, but he told me it was from the piaware build page flightaware.com/adsb/piaware/build, and it was named similiarly to the 1.14.3 one that I got to work.


#14

I suspect that he clicked over to the raspberry pi website and downloaded the file instead of the piaware image. Before, when it booted, it looked exactly like the 3:00 mark of this video:http://www.raspberrypi.org/help/noobs-setup/

There is a link to that page on the flightaware.com/adsb/piaware/install page. Perhaps that confused him… The layout of the piaware webpages is quite confusing and I could see where a novice user would be confused by the different pages. Thanks,