PiAware 1.14 released


#1

Hi, everyone. I’m pleased to announce the release of PiAware 1.14.

This release has a number of important improvements and bug fixes that address reliability, position reporting accuracy, and allow PiAware to run on more versions of Linux without modification.

People who installed from the Debian package can find upgrade instructions at flightaware.com/adsb/piaware/upgrade

People who installed from the PiAware image can either grab the new image or you should be able to install the Debian package from the link above.

Full release notes can be found here: github.com/flightaware/piaware/ … ease-Notes

Thank you for your interest and participation.

-Karl

[UPDATE - problem with 1.14, stay with 1.13 for now. We are re-rolling 1.14.]


#2

My PiAware seems to have stopped uploading data when I upgraded to 1.14. It could be that I upgraded at 11:30 PM, so not much air traffic at this time; however, I am in Atlanta and I know ATL has flights 24/7. I guess we’ll see tomorrow if it’s pushing data.


#3

There’s a problem with piaware not starting properly in 1.14. I’ve rolled back the webpages to show 1.13. A shared library versioning problem.


#4

As in:
application-specific initialization failed: can’t find package Tcllauncher exactly 1.5
can’t find package Tcllauncher exactly 1.5couldn’t read file “/usr/lib/Tcllauncher1.5/tcllauncher.tcl”: no such file or directory
?

Since I neglected to make a cya copy of 1.13, I ended reinstalling.
Time to relearn where Linux puts things…


#5

Yeah.

The .deb package is back up and that problem is fixed. If anyone would like to test, follow the install instructions at flightaware.com/adsb/piaware/fil … _armhf.deb

I’ve rebuilt the image but I’ve got to get help getting it onto the CDN so it won’t be up until tomorrow.


#6

Just tried 14-1. I got an faup1090 error, “Error opening the listening port 30005: Address already in use”.

Tried killing and restarting dump1090 & ppup1090, same result. Reverted back to 13-1.


#7

1.14 is broken. It wasn’t tested enough. The software has reached a level of stability and there are so many people using it that we need to do more testing before releasing, and I apologize for any problems people experienced.

The 1.14 .img file works OK because it doesn’t need faup1090. We’re fixing it and we’ll post a beta version within the next two days.


#8

I can’t even get 1.14 to open the zip file…
I get a “Windows Cannot Open the folder” message. (Win 7, 32bit)


#9

It isn’t a zip file or something you should be downloading on a Windows computer. You should download it directly from the Pi using the indicated commands. Check here for the latest version of 1.14 – post151269.html


#10

Just to clarify, this thread is for people who installed PiAware manually on an existing Pi, not users of the PiAware images.