Pi Zero With 7.1

I just bought a kit from the Flight Aware Store, have followed the instructions and can’t get my Pi Zero that came with the kit to connect to my internet. There are no specific instructions for the Pi Zero W. Are there any gotchas for setting up a Pi Zero with 7.1?

Did you try the bluetooth setup? are you sure it’s version 7 on your sdcard? Prior versions didn’t have that option.

Thank you for the reply.

Here’s what I’ve done since I posted:

I’ve tried a few different power supplies to see if it was the cord. The one that came with the FA kit was a Canakit brand plug, 2500mA.

I’ve tried a different SD card. The one that came with the kit—a Sandisk 16GB—and another 32 GB I had.

I’ve tried to load straight Raspberry Pi OS as well as PiAware from the website.

I’ve used Etcher on a Windows computer and the Chromebook Recovery Tool to load.

I plugged the Pi into a Windows machine and I found it on the Device Manager.

I have an HDMI splitter plugged into a monitor. I haven’t had a signal yet.

I plugged a USB to SD Card reader into the USB port to see if it would boot from a USB.

I’ve also tried the Bluetooth setup, but haven’t seen it on my browser.

Since the HDMI has been plugged in and the monitor hasn’t detected a symbol, it seems like I have a boot problem, not just a wifi problem.

Any other ideas? Thanks in advance.

I would advise you to use the Raspberry Pi imager available here

Use the option to set host name and ip adress and SSH acces using ctrl+shift+x

Then you can load the image on the Pi zero and then boot it headless ( without keyboard, mouse or screen) and you login to the Pi via SSH and install the piaware and dump1090-FA packages from there onwards via the desciption on the following page

I have a bad pi. It won’t boot anything and when I try to ping it from my desktop I’m not getting a response.

Thanks for the help.

I wonder wether a Pi Zero W is a good choice. I used one with dump1090-mutability and fr24feed for quite some time experiencing random locks. Finally I discovered frequent CPU loads of 100% which means the machine could not handle the number of messages to process. So I moved to the new Pi Zero W2 which is promoted to provide 5 times better processing power. With raspbian bullseye, piaware and fr24feed it runs at about 10% CPU load now.

I’m running 7.1 on the Pi Zero kit purchased through the FA store. I initially installed an older version, got everything up and running per the instructions, and subsequently upgraded to 7.1 through the stats page on the web interface. Have you tried loading an older version to see if it works?

I also see 100% CPU load both with the older version and now with 7.1 and will likely upgrade to a more powerful Pi but it still works without issues for now.

You should upgrade to dump1090-fa as mutability is not supported any longer. That can also impact your experience regarding CPU usage.

I run a Zero W 24/7 - just an indoor antenna sitting on a can by a window. I am around 14 miles from Heathrow. Pre pandemic would get around 1800-2000 aircraft daily which included mlat - feed FA FR24 and ADSBx

Zero W performs fine.

Obviously dependant on any other tasks that may be installed being carried out by the Zero. This hobby can be addictive, start with basic tuner and antenna then upgrade to outdoor antenna, filters, include graphs and charts then poor old Zero runs out of steam.

Horses for courses as the saying goes.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.