FlightAware Discussions

Raspberry Pi Zero W

Hi all,

I had my RPiZW working for a long time, lets say 400+ days with no issues so far.
Now for a unknown reason it didnt connect to my wifi network.
Connnected it to my TV, and started it. Its showing WLAN0 down.
If i go to raspi-config and configure the wifi again, it connects to my network but if i reboot it, it no longer connects. If i go again to raspi-config and setup wireless it connects again but some times it does not.
The piaware-config.txt file is correctly setup and my wireless key and ssid is also correct, my wifi network has other clients connected withou any issues.
It seems that the wifi is not beeing set as UP on boot.

Any ideas?
Thanks in advance.

Kind regards,
Rodrigo

A few possibilities but hard to know.

Did you put it in a metal case that could be attenuating the wifi signal?
Can you log into your home router/wifi access point and check signal strength when it connects?
Have you moved your router/wifi access point in your home? Any other changes to your router/wifi?
Have you looked at your log files to see if any clues there?
Do you have another Zero you could try with the problem Zero’s SD card? (Maybe it’s hardware?)
Have you upgraded firmware on your router? Likewise, do you upgrade the OS on the Pi? Sometimes incompatibilities can be introduced.
Do you have another SD card you could load Raspbian onto to see if there might be a corruption issue causing problems?

Hi Robert,

The RPi is on my attic, the wifi there is strong, there were no changes on my router or access point.
I’ve moved the RPi just next to the AP and same issue. I tried to connect the RPi to another access point with the same issue.
Right now i dont have other RPi but will clone this SD card to another. The settings on the piaware-config.txt are saved as what i have changed are still stored there.
The RPi is set to update flightaware automatically.
Regarding to wifi, this is what i see on the logs:

wpa_supplicant[352]: wlan0: failled to initiate sched scan

Kind regards,
Rodrigo

The /etc/network/interfaces for wifi is set like this:

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wireless-power off
wpa-roam /etc/wpa_supplicant/wpa-roam.conf

This is a fairly “normal” wpa_supplicant bug of some sort, it’s harmless AFAIK.

I would suggest reimaging with a Buster image.

Hey Rodrigo, I am not fluent with Pi wifi but found this: https://www.raspberrypi.org/forums/viewtopic.php?t=201850

It’s from 2018, though, and I don’t know if there have been relevant changes to the OS since then or if everything there still applies.

One other thing you might try is rebooting your router/wifi - one of the suggestions on that page. A number of those have had issues with establishing and holding connections of various flavors and a reboot, where that is the problem, generally fixes the router up until it gets confused again. Only thing is that you tried another access point. That might make this less likely unless they are same kind of router.

It’s expense, but you could always get a new Zero and try that with this SD card. If a new Zero behaves the same, it’s probably not the Zero.

One other thing, how hot is your attic? Maybe less likely, but in service for a while at elevated temperatures may have induced a failure?

Good luck!

Hi Robert,

It’s probably my Zero…
I’ve flashed another SD card with the same results…
I will order a new one.
Thanks a lot for your help!

Kind regards,
Rodrigo

A clone of your existing card, or a virgin install?

Have you tried rebooting your router?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.