FlightAware Discussions

Pi does not see dongle .It appears to be the software

I have swapped out everything ,pi ,dongle,etc. except SD card.
Any ideas anyone ?
Frank S.

If you have a spare microSD card:

(1) Download latest image and write it to the spare microSD card

http://piaware.flightcdn.com/piaware-sd-card-4.0.img.zip

(2) To configure, follow instructions in QuickStart Guide ( except step 1 which will download old image ver 3.8.0)

Can’t do diagnostics without a clear description of the problem.

Please clearly describe the problem you are having, including logs if available.

When I power up the pi zero w ,I am using a purchased preprogrammed sd card ,
everything looks ok.
However when I log in to it’s IP address, I get Piaware running and logged in to Flightaware,
but Not connected to ModeS receiver.I am using a Flightaware Blue dongle.I have swapped connecting lead and power supply to no avail.
This setup work since last year then started acting up.
I also swapped the dongle with same.

The Zeros seem to have some reliability problems; have you tried swapping the Pi out?

You could also try a fresh image as abcd suggested above.

Hi,
I’ve swapped the zero for another to no avail.I’ll try B+.
If it does not work I’ll flash another card.
Thanks

Hi Everyone,
I seem to have solved the problem,ie the connector between the Pi and the Dongle.
It occured to me that this was the only part that I had not swapped.I put a USB Hat on the Pi,plugged in the Dongle directly,fired it up and Hey Presto ,back in business.
An interesting lesson learned .
Thank you all for your help.
Merry Christmas