PiAware 7 SD Card Image Released

The PiAware 7 SD Card Image is now available for download and Beta testing!

New Features:

  • Operating System: Debian Bullseye
  • Boots on Raspberry Pi Zero 2 W
  • Connect your receiver to WiFi using a supported Web browser, iOS, or Android device
    • This features uses Bluetooth Low Energy (BLE) to communicate with your device
    • More information on this Wi-Fi setup can be found in the PiAware Setup Guide in the image ZIP file.
  • Minor bug fixes and improvements to piaware, dump1090-fa, dump978-fa.

This release ends support for Jessie OS . If you are still on Jessie, we highly encourage you to re-image your SD card with PiAware 7 or upgrade your OS to continue receiving updates.

If you are re-imaging an existing setup, be sure to back up your SD card and reclaim your unique feeder-id after re-imaging. Re-imaging and reclaiming instructions can be found at PiAware - Upgrade PiAware to the latest version - FlightAware. Note that if you are testing the new Wi-Fi setup via web or mobile device without reclaiming your feeder-id, it will automatically claim a new feeder-id on your FlightAware account. You should set your existing feeder-id via piaware-config.txt if you want to resume your statistics.

The official release will be available for update in a few weeks.

If you have some spare hardware laying around or have some time over the holidays, try it out and and let us know if you see any issues. Please provide which Raspberry Pi model you are testing on. We’re looking for users with Raspberry Pi Zero, Pi Zero 2 W, Pi 3B+, and Pi 4s.

PiAware 7 SD Download Link: https://piaware.flightcdn.com/piaware-sd-card-7.0.img.zip
PiAware 7 SD (LCD support) Download Link: https://piaware.flightcdn.com/piaware-sd-lcd-card-7.0.img.zip

Happy Holidays!


Simple to install and seems to work.

SITE 93830



Well done.


Hmmm … first pass has been a failure.
Site 81771
Not sure it the Pi is a 3b or 3b+.
Burnt a clean image and only added UUID and SSH.
The Pi appears not to be booting.

Up and running!

If you have a monitor you can hook up, does it get to the rainbow screen? does it get past the rainbow screen?

edit: boots OK here on Model : Raspberry Pi 3 Model B Rev 1.2

All good.
Turned out to be a power problem. Reseating the PoE cables has brought it up.

Heh. It’s always power! Thanks for testing it out :slight_smile:


The first test was on a Pi 3B Plus

I then took the MicroSD card andinstalled it in a Pi Zero 2W and all worked as expected.

Tar1090 and Graphs1090 seem to be working correctly too. Thanks @wiedehopf .



yeah, isn’t it just!

For completeness, it’s a Pi 3b+ v1.3


Wrote Piaware SD Card image ver 7.0 to 8 Gb microSD card
Added file ssh in /boot partition
Added WiFi credentials in /boot/piaware-config.txt
Slipped microSD card into RPi Model 4, 1 Gb,
Could SSH, but now MAC address for WiFi is that which was previously (ver 6.1) for Wired Connection.

Tried to claim from Android Phone’s browser, using Bluetooth, but failed.
Finally edited file /boot/piaware-config.txt and at bottom added following line (existing feeder-id) and rebooted
feeder-id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx


Screenshot - 1 : Configure PiAware by Bluetooth - FlightAware



Screenshot - 2 : Perpetual rotating wheel

If you’ve manually configured wifi, then BLE wifi setup is disabled.


Yeah what Obj said. The idea being if you configured WiFi manually, you should be able to do it again.

Two things you could do:

  1. Set allow-ble-setup to yes which will enable Bluetooth if your receiver ever has trouble connecting to WiFi
  2. Reimage and only enable ssh and set your feeder-id. Bluetooth should be enabled then.

I flashed 2 Mode-S nodes (Raspberry Pi 2 Model B Rev 1.1) and 1 UAT node (Raspberry Pi 3 Model B Rev 1.2). All 3 are connected via wired Ethernet. This is the only unexpected thing I’ve encountered.

pi@piaware:~ $ sudo apt update
Get:1 http://flightaware.com/mirror/raspbian/raspbian bullseye InRelease [15.0 kB]
Ign:2 http://flightaware.com/adsb/piaware/files/packages bullseye InRelease
Get:3 http://flightaware.com/mirror/raspberrypi/debian bullseye InRelease [23.5 kB]
Err:4 http://flightaware.com/adsb/piaware/files/packages bullseye Release
  404  Not Found [IP: 80]
Get:5 http://flightaware.com/mirror/raspbian/raspbian bullseye/main armhf Packages [13.2 MB]
Get:6 http://flightaware.com/mirror/raspberrypi/debian bullseye/main armhf Packages [242 kB]                                     
Reading package lists... Done                                                                                                    
E: The repository 'http://flightaware.com/adsb/piaware/files/packages bullseye Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

This is because we haven’t done the full release yet, so the bullseye repository isn’t there yet.

Working well on a Zero 2 W.

Works now on the Pi 2 as long as MLAT is turned off.

How is 7 doing on Zero and Zero W’s? Fingers crossed that it is a lighter OS and frees up some CPU.




Thanks @obj and @eric1tran
Just to get familiar with this new and very useful Bluetooth feature, tonight I will try both the options suggested by @eric1tran and post the results.



No problems here, Pi 4 with 4GB, airspy R2, @wiedehopf Tar1090, Graphs and Airspy scripts.

No other feeders installed yet

1 Like

I have a Pi Zero W Rev 1.1 sitting in a draw and tried Wireless Setup over Bluetooth LE

Started with a newly flashed SDcard and added the SSH file.

Placed the SDcard in the Pi Zero W and follwed the instructions using a Chrome browser in my Android phone.

It found the Pi and correctly configured the WiFi credentials I supplied for my local AP.

It has the network name PiZeroW.

I can SSH to it.

I haven’t added a receiver but it did claim a new station. Site 166572.

I did receive an email titled Maximum Sessions Reached on FlightAware Account and I was logged out of the stats page. I could log back in.

The PiZeroW is VERY slow and I do not use it as an ADSB receiver.

My Pi 3B continues running Piaware 7 without problems.



Installed on to a Zero W - password problem.

Using ssh twice I changed the password, both occasions it said successful but both occasions I had to login with the default password as it kept indicating wrong password.

pi@piaware:~ $ sudo passwd
**New password: **
**Retype new password: **
passwd: password updated successfully
pi@piaware:~ $ exit
Connection to closed.
geoff@satellite:~$ ssh pi@
**pi@’s password: **
Permission denied, please try again.
**pi@’s password: **
Permission denied, please try again.
**pi@’s password: **
Linux piaware 5.10.63+ #1488 Thu Nov 18 16:14:04 GMT 2021 armv6l

I’ll check my SD card but as wifi details writing to wpa_supplicant.conf I am guessing it is OK.


sudo passwd changes the root password not the pi password
just use passwd to change the pi password.


How did I fall for that one :joy: :joy: :joy:

My mistake, apologies.