FlightAware Discussions

Pi Power issues and Receiver Project Scripts

Hi,

I have 2 Pi’s (version 3B) running the ADS-B Receiver Project setup / scrips. One aerial (after about 15m cable) goes into a habamp / filter and then gets split and goes to an original orange dongle on one Pi and a newer blue dangle on the other Pi.

Both of the Pi’s are powered by POE, for the orange dongle one I have a POE splitter at the Pi end, and the other end goes into the POE switch. For the blue dongle one I have a TPlink POE injector at the switch end (from a non POE port) and then a TPLink splitter at the Pi end.

Everything has been working fine for 5 months (and before that about 3 years before I was off-line for about 6 months due to a house move).

Anyway, the other week I got a email from Flight Aware saying that my system had been off-line for 6 hours. Looking into it and it turns out that the Blue dongle Pi was off. I tried power cycling it, and it came back up, but after a while it want off again. Power cycled it again and it came back up, I then looked at the performance graphs and saw that for about the previous week there had been may times when data was unavailable (but not longer then 6 hours so hence no email from Flight aware). I check all the cables etc and all looked ok, so I got a spare 5v power supply and managed to connect it up to the blue dongle Pi, and it booted up, and worked ok for several days. Assuming that something may have gone wrong with the TPlink injector / splitter (and now having a spare POE port) I brought a similar POE splinter to the one powering the other Pi.

When it arrived I powered down the Pi, and connected up the new splitter, the lights on the RJ45 end lit up to show power, but as soon as I plugged the micro usb connection into the Pi the lights dimmed / went off, and the Pi failed to power up. I decided to try again but with the blue dongle disconnected, and this time the Pi powered up, but once it was up as soon as I plugged the blue dongle back in it crashed with a lack of power. I also tried with the Blue dongle plugged in, but the aerial lead disconnected, and that powered up, but crashed as soon as the aerial was connected back in.

The other Pi works ok on a POE splitter and this Pi worked fine on the TPLink injector / splitter uptill 2 weeks ago, and with nothing else changing I am wondering if something has gone a bit wrong with the Blue dongle, and is maybe causing a power overload. The Pi / Dongle works fine with a proper power adapter, just not over (2 types) of POE.

Anyone else experience anything like this or a faulty (blue) dongle.

While I’m here, as I said I am running the ADS-B Receiver Project setup / scrips, however not sure that is the best solution now. I upgraded to the latest version when I re-set up my systems 5 months ago, but I notice that https://www.adsbreceiver.net/ doesn’t work, and the project scripts don’t seem to have been updated in quite a while.

I liked the extra graphs / stats and web page that the Receiver Project provided, as well as being able to run the script to find the best gain. Am I correct in that it seems that the performance graphs / stats can now be added to the standard Pi Aware build, and also a “improved” web page. If so, is it worth sticking with the Receiver Project setup, or re-freshing with the latest Pi Aware build and trying to add the graphs and web site.

With Thanks, Ian.

Best solution :+1:

(1) Latest Piaware SD card image

Howto : Piaware SD card image 3.8.0 Quickstart Guide

Note:
Although the above howto is for ver 3.8.0, it is fully applicable to latest ver 3.8.1 also.

However the image download link given at start of the post is for old ver 3.8.0. Please dont it. Instead use this link for current image 3.8.1

http://piaware.flightcdn.com/piaware-sd-card-3.8.1.img.zip

(2) Graphs by Wiedehopf.

Use this bash script to install the graphs.

sudo bash -c "$(wget -q -O - https://raw.githubusercontent.com/wiedehopf/graphs1090/master/install.sh)"

To view graphs in browser:
IP-of-Pi/graphs1090

 

@iandrews

You will have to reinstall all other feeders, but it is not a big deal.

Before you write fresh image, copy-paste feeder keys in Notepad on your desktop/laptop and save notepad:

Plane finder key:
The sharecode is in the file /etc/pfclient-config.json
Scroll right to see it in full. Your Planefinder sharecode is the last item in this long line.

{"tcp_address":"127.0.0.1","tcp_port":"30005","select_timeout":"10","data_upload_interval":"10","connection_type":"1","aircraft_timeout":"30","data_format":"1","latitude":"xx.xxxx","longitude":"yy.yyyy","sharecode":"zzzzzzzzzzzz"}    

Flightradar24 key:
The fr24key is in the file /etc/fr24feed.ini

Radarbox24 key:
The key is in the file /etc/rbfeeder.ini

Installation commands

Planefinder

wget http://client.planefinder.net/pfclient_4.1.1_armhf.deb  

sudo dpkg -i pfclient_4.1.1_armhf.deb  

Flightradar24

sudo bash -c "$(wget -O - https://repo-feed.flightradar24.com/install_fr24_rpi.sh)"  

Caution: , During configuration of fr24feed, never choose “Receiver DVBT”. Choose Receiver: ModeS Beast(TCP), host/port: 127.0.0.1:30005

Radarbox24:

sudo bash -c "$(wget -O - http://apt.rb24.com/inst_rbfeeder.sh)"  

sudo rbfeeder --setkey xxxxxxxxxx --no-start   
## Replace xxxxx by your actual key
## Press Ctrl+C to break log output.

sudo systemctl restart rbfeeder  

Can you swap the Pis? In other words, say you have Pi “A” connected to your orange stick and Pi “B” connected to the blue one - just unplug everything from both Pis and switch them. Now, the Pi that was working correctly when attached to the orange stick and the POE Splitter, attached to the blue stick and POE injector - and vice versa.

Does the problem recur? If so, did it move with the Pi over to the orange stick, or stay with the blue one? If it moved, there is something wrong with the Pi. If it stayed, it is either the blue stick or the power. Try swapping the sticks now. Did the problem recur? If so, did it move with the blue stick, or stay with the Pi? If it moved, it is the blue stick. If it stayed, it is the power.

Effective troubleshooting is all about isolation and elimination. And you can’t let assumptions color your logic. You can’t start out with “It can’t be the power supply, I just replaced that!”. You are in an ideal situation for troubleshooting because you have two units and can swap components for testing. Just remember that if something that you do changes the symptoms - even if it makes things worse - then you are probably on the right track.

3 Likes

I’ve had two PoE splitters fail and leave the Pi’s unstable / unreliable (now failed).

Thanks for the replies, I have done a bit more experimenting, and it seems that if both Pi’s are powered over POE then as soon as both Pi’s (dongles) are plugged into the splitter (a MiniCircuits ZAPD-21) one of the Pi’s crash, this is even when there is no aerial input going into the splitter. Most of the times it seem to be the same Pi when either the blue or orange dongle was connected to it, but at least one time it was the other Pi when the Blue dongle was connected to it. I also swapped the connection to the dongles between splitter output 1 and 2, but it seems to make no difference to which Pi crashed.

I also (temporarry as it’s on a different subnet) feed the Blue dongle Pi via a spare POE port on my IPCam switch and it seemed to be stable and not crash.

So, starting to think that there is maybe some kind of ground / power short between the 2 Pi’s when both powered over POE (via the same switch) that is coming via / being caused by the splitter. Though not sure if it’s the (blue) dongle / Splitter / specific Pi at fault.

Ian.

If there is a short, your POE thing is at fault.
Either on the side of the pi, or the side of the switch.

Anyhow you should be able to test the issue measuring between Pi grounds (usb housing works).

1 Like

Just tried a old nooelec dongle in place of the Blue Flight Aware one, and same issue, so assume its not the dongle.

Sorry, how would one do / test that. I have a multimeter.

Ian.

First test, with the dongles off, use the multimeter with probes on the different pies touching the USB metal box. This will tell you if there is a difference between the two pi’s grounds from your POE devices. Assuming there is no faulty grounds, connect the dongle receivers and measure the voltage at the same USB metal boxes. If you have a change then a dongle may have a problem. Also measure the voltage between the USB metal box to the the dongle SMA connector. It should show no voltage. Do that on both dongles. Last, compare voltage between the two SMA connectors. It should be zero volts. You will be using the most sensitive ranges on your multimeter. Good luck, interesting problem.

1 Like

Interesting… With both Pi’s powered over POE, the one with the orange dongle with the POE splitter that’s been in use for about 3 years, and the blue dongle with one of the new POE splitters just ordered, I disconnected both dongles and measured between USB ports on both Pi’s. The reading was about 42 volts!! Just to be sure I used 2 different RJ45 cables from the switch to the splitters and got the same.

I then had a thought, because the Pi with the blue dongle was the one that had been crashing / not powering up, that’s the one I had assumed had the issue, and the one where I had changed the old TPLink injector / splitter to a Mains adapter (that worked ok) and then tried one of the newly ordered POE splitters (that didn’t work), and I hadn’t done anything to the splitter powering the orange dongle Pi. So I disconnected it’s original POE splitter and put in a 2nd new splitter (I had ordered a a dual pack), and now the reading between the USB ports on the 2 Pi’s is about 0.15V.

I assume that the reading of 42Volts I got between the Pi’s is not to be expected, and was the issue, and that’s why when the 2 dongles (Pi’s) were connected via the aerial splitter it caused one of the Pi’s to crash.

I can only assume something has caused the original POE splitter to the Orange dongle Pi to go wrong, and to cause a voltage to be present where it shouldn’t be, though not sure why 42volts when the Pi’s are being supplied 5volts, but then again I think POE voltage is about 48volts.

Ian.

1 Like

Interesting problem. I guess that signal ground is connected to USB & electrical ground, and the different POE supplies provide a different ground bias (at a guess, one ties ground to the POE negative supply, while the other ties +5V to the positive supply).

48V   ------ first Pi, +5V
 .
 .
43V   ------ first Pi, 0V / ground
 .                           ^
 .                           |
5V    ------ second Pi, +5V  |  here's your ~ 42V
 .                           |
 .                           v
0V    ------ second Pi, 0V / ground

(“ground” is a slightly nebulous concept; devices only really care about relative voltages, so they can happily have their “0V” line floating at 42V above “real” ground … so long as they’re not connected to something with a different idea of where 0V should be!)

2 Likes

So, both Pi’s have been running ok on the 2 new POE splitters for the last few days.

I remembered the old splitter (that I suspected of being faulty) powering the orange dongle Pi has a round male DC plug on the end of it, and I was then using a short dc plug to micro usb cable to then go into the Pi. This meant that it was easy for me to measure the voltage coming out of the splitter, and it measured 53volts when I suspect it should have been 5. Suspect this 52 volts is the direct voltage coming in over POE, and maybe a component that should step it down to 5 has failed.

I can only assume this high voltage was the cause of the voltage mismatch issues between the Pi’s, however I would have thought that if such a high voltage was being fed into the Pi it would have blown something on it.

edit: removed mistake.

Wait, nvm.
Basically it uses the wrong thing on the Ethernet as ground reference.
Not sure if POE has a standard what to use as a ground reference.