Odroid XU4


#1

Just got an Odroid XU4, to try out. Now planning to try 1090 Muatability, what do I have to do, use a current mico sd that has been running 1090 muta or do I have to use an different file system???


#2

You cannot use Raspbian (Jessie or Stretch) on Odroid XU4.
Following images are for Odroid XU4. Write one of these to its SD card (or eMMC Card ???)

https://wiki.odroid.com/odroid-xu4/os_images/linux/ubuntu_4.9/20171025

https://www.armbian.com/odroid-xu4/


#3

#4

Thanks. Just been trying Ubuntu and SSH putty. Couldn’t work out passwords etc so with try ambrian, hopefully the login/pasword will be easier. Once I get it up running, how do I load the 1090 mutability files?


#5

that was much easier. Now logged into debian. Now I suppose I have to download all the 1090 files??


#6

ADS-B Receiver Project Setup Scripts


#7

Yes,I manually downloaded it but got some weird host name pop which ever time the program does something, it can"t resolve. “sudo:unable to resolve host radarcape” and the host appears to be debian@radacape or similar???


#8

I think I have found how to solve the host issue. However, using 1090 mutability under a different operating system is new to me. I have loaded 1090 mutability in the ADSB directory of my debian but I am used to PI, turn on and away you go, how to you boot into 1090 in such a set up??


#9

H E L P… I am lost at how to get the Odroid to work with ADSB. As mentioned above, I have solved the host name issue. I re imaged the micro and when it booted with basic Debian, I got the proper SSH login page, set up for passwords and users etc, so that is working ok. Now I know, I think, I will have to manually download Joe’s 1090 mutability files, into a created ADSB-receiver dir, on the debian loaded micro card, all this is as per the PI manual setup basically.

But can someone point this new Odroid debian user as how to get the ADSB program running??? As mentioned above, only use to putting the relevant image onto a micro, putting that into the PI, power up and going to the relevant local network page to observe the results. Pointing to an idiot proof step by step will work. With my ADSB ventures, I have managed to become somewhat proficient with PI, scripts etc and with your help, just need to grasp the Odroid and Debian way of running things. Hopefully when I get that mastered, my Airspy R2 should be here in a couple of days, then I will try to implement that into the Odroid set up, but got to get the basic mutability working first. :slight_smile: Help;)


#10

.

It is very simple, IF you can SSH to Ordroid from your Desktop/Laptop/Tablet/Phone

.

sudo apt-get update   

sudo apt-get install git   

cd ~/   

git clone https://github.com/jprochazka/adsb-receiver.git   

cd ~/adsb-receiver   

chmod +x install.sh   

./install.sh   

.
Last command will open a dialogue and present choices of dump1090-mutability/dump1090-fa, data feeders, and Web Portal/Graphs. Choose what you want to install.

EDIT
You dont have to choose everything in the first attempt. For example you can choose only dump1090 (mutability OR fa), and say NO to everything else (i.e. data feeders, web portal etc). Once dump1090 is installed and funtioning, you can repeat two commands given below, and add more items. You can repeat the two commands below even a 3rd, 4th and 5th time, and keep on adding items.

cd ~/adsb-receiver   

./install.sh   

#11

Yes, thanks, I have got that far and all the files are in the adsb-receiver directory in the Odroid. It is the next step, As mentioned, with PI, put the micro in, power up and away you go. At present with Odroid, micro is in but obviously, there is more on the micro that just 1090 files. How in this situation, to you get your ADSB running?


#12
  1. Did you run these 3 commands and installed dump1090 (mutab or fa)?

    cd ~/adsb-receiver
    sudo chmod +x install.sh
    ./install.sh

  2. Please give following commands and post output of each command. The outputs will show what is installed, as only download is not enough. The downloaded files should be built & installed after download.

    apt-cache policy dump1090-fa

    apt-cache policy dump1090-mutability

    apt-cache policy piaware


#13

Yes I issued the 3 commands as above, mutability. After the download, i went through the install process to install the various options that are offered. At this stage, I only chose Flightaware and the web portals. I am not with the unit so a reply re the apt requests will be about 10 hours away. :slight_smile: thanks


#14

jeff@odroidxu4:~/adsb-receiver$ apt-cache policy dump1090-fa

dump1090-fa:
Installed: (none)
Candidate: (none)
Version table:
jeff@odroidxu4:~/adsb-receiver$

jeff@odroidxu4:~/adsb-receiver$ apt-cache policy dump1090-mutability

dump1090-mutability:
Installed: 1.15~dev
Candidate: 1.15~dev
Version table:
*** 1.15~dev 0
100 /var/lib/dpkg/status
jeff@odroidxu4:~/adsb-receiver$

jeff@odroidxu4:~/adsb-receiver$ apt-cache policy piaware

piaware:
Installed: 3.5.3
Candidate: 3.5.3
Version table:
*** 3.5.3 0
100 /var/lib/dpkg/status
jeff@odroidxu4:~/adsb-receiver$


#15

Good, you got them installed.
Now check if these are funtioning ok:

sudo systemctl status dump1090-mutability

sudo systemctl status piaware

If all is ok, the last few lines of output from status piaware command should say xxx mesages received from dump1090 mut, yyy messages sent to flightaware


#16

I have actually got it working once, directly after finishing doing the portal install, viewed the maps, graphs etc. But the big test, re powered up the odroid, can connect via SSH, can change directories to the adsb-receiver but I can not for life,connect to the local ip addresses to see maps, graphs etc. I have even given the piaware and mutability restarts via SSH, just will not let me view the local address pages. My LAN is recognizing the Odroid, I dont believe there are any firewall issues as I am SSH’ing fine. The 2 commands above post worked, indicating everything is working ???


#17
sudo lighty-enable-mod dump1090   
sudo systemctl force-reload lighttpd  

After this, try
IP:8080
IP/dump1090/gmap.html


#18

That would be a no on all accounts, same situation

This site can’t be reached
172.16.0.21 refused to connect.

And must be working as I have received the flightaware email of re connection for that new ID. It must be some Odroid thing???


#19

What is the output of this command?

sudo systemctl status lighttpd


#20

jeff@odroidxu4:~/adsb-receiver$ sudo systemctl status lighttpd
● lighttpd.service - Lighttpd Daemon
Loaded: loaded (/lib/systemd/system/lighttpd.service; enabled)
Active: failed (Result: exit-code) since Mon 2018-06-04 16:14:24 CEST; 17h ag o
Process: 735 ExecStart=/usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf (c ode=exited, status=255)
Process: 619 ExecStartPre=/usr/sbin/lighttpd -t -f /etc/lighttpd/lighttpd.conf (code=exited, status=0/SUCCESS)
Main PID: 735 (code=exited, status=255)

Jun 04 16:14:24 odroidxu4 lighttpd[619]: Syntax OK
Jun 04 16:14:24 odroidxu4 systemd[1]: Started Lighttpd Daemon.
Jun 04 16:14:24 odroidxu4 lighttpd[735]: 2018-06-04 16:14:24: (log.c.118) op…y
Jun 04 16:14:24 odroidxu4 systemd[1]: lighttpd.service: main process exited…/a
Jun 04 16:14:24 odroidxu4 systemd[1]: Unit lighttpd.service entered failed …e.
Hint: Some lines were ellipsized, use -l to show in full.
jeff@odroidxu4:~/adsb-receiver$