NXXXX is expected to arrive at KXXX in 30 min

Is there a way to turn this notification on/off? I only have the Scheduled notification checked.

Also my Sessions list is showing some of my logins from Eugene OR, and I’m in TN.

Go to your alerts flightaware.com/account/manage/alerts, select the alert you would like to remove the minutes out alert from. Click on advanced options, deselect the check box for “Also alert me before the flight arrives”

Im not sure about the IP from Oregon. You can change your password and clear out all your sessions at flightaware.com/account/manage/sessions if you are concerned someone if you think someone may have access to your account. Additionally, we offer two-factor authentication if you would like to turn it on on your account.

OK, I found the “Also alert me” box. IMO that option should be down in section 3:

Receive an alert when the flight is:
XX minutes away from the destination

FYI it’s set to 45 mins, but alerts at 30 mins.

As far as the session, I can tell it’s my login showing OR.

There is quite a bit of calculation that goes into determining 45/30/15 minutes out and we may delay sending it on shorter flights to increase the reliability of the estimated minutes out. We also would be sending the departure message and then the 45 minute out message back to back on shorter flights.