Not receiving alerts Android app


#1

I downloaded the Android app for my HTC Thunderbolt last night to be able to track my daughter’s flights to Germany today. I have enabled alerts several times on both my phone with the app and on the computer, but haven’t recieved alerts on either of them. What am I doing wrong? (forgive my noob-ness please!)


#2

I’m having this problem as well. I have tried to set alerts many times, but have only had them work 1 or 2 times out of probably 20 attempts. Using a Nexus S 4G with Android 4.0.4


#3

Same here. It hasn’t worked for a while now, a month or so. It used to work flawlessly, my wife has it, my mother, as well as some friends, all on Android, and no one getting alerts any more. (Nor am I, I have it on my phone as well, for other pilots and friends.)
Anyone know what’s going on, if FlightAware is aware of the problem, and if anything is being done about it?

Cheers,
Helge


#4

We’re aware of the problem, but we believe the problem might be due to Google’s C2DM messaging service being deprecated (even though they claim it should remain operational for current apps). We’re in the process of preparing a new app update that migrates to the new GCM messaging service, but it’s probably still a couple weeks away because there are other server-side changes we have to make, plus some more app fixes to test.


#5

Alerts should now be working for both the existing Android app and the new version that was released a couple days ago. (We identified a workaround we could apply to our servers for just the old app, but the new app fixes the problem in a more general way.)