No local access to piaware

I can access Skyaware anywhere and I’m feeding data, but any attempts at access to access piaware locally result in “Safari can’t open the page “‎192.168.7.157:8080” because the server unexpectedly dropped the connection. This sometimes occurs when the server is busy. Wait for a few minutes, and then try again.”

I actually downloaded the most recent image and reflashed my SD card but still no dice. Any ideas on how to troubleshoot this? (verified that it is the correct local IP address, etc)

Thanks

Matt

Hi Matt, VPN?

Is there any chance the computer running Safari has a Virtual Private Network enabled, either for the entire system or just within the Safari browser? That would block the connection unless you enabled a feature called something like below.

Allow LAN Traffic

Always permits traffic between devices on your local network, even when using the VPN.

With Firefox, the error message without local LAN traffic allowed is as below. Your message said disconnected, not failure to connect, so you might have a different problem.

Firefox without LAN traffic allowed during VPN use.

Unable to connect

Firefox can’t establish a connection to the server at 192.168.0.115:8080.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the web.

Good luck,
-Dan

1 Like

Try this 192.168.7.157/skyaware

1 Like

Thanks; no VPN at all tho. I have a few other raspberry pis and can access them without any issue.

Thanks; no dice I’m afraid.

What do you get at just 192.168.7.157

On a whim, I ran a network cable over to the pi and rebooted and that did the trick. Not sure why WiFi wouldn’t work, is this a known bug? (at some point, it did work fine over WiFi; I’m honestly not sure when this problem started)

This sounds like a wifi connection or router problem, not a problem with the image.

I definitely considered that but I believe I’ve ruled out any network/wifi issues.

First, the error “unexpectedly dropped the connection” (as opposed to the general “not found”, etc) usually means the browser was able to open a connection, but the response back was lost - which could mean the host was answering on one network interface and attempting to reply on another.

Also, the piaware was reporting data back to flightaware without any problem, and was responsive to commands sent via the settings page there - so there was at least some baseline connectivity.

I also have other pis running over wifi without issue, but to completely rule out a network issue, I put a fresh install of raspbian on a new SD card and configured it with the same wifi connection. I shut down piaware and swapped it out for the other card, and I was able to fire up a quick web server on the same hardware in the same location and it responded just fine locally.