Newbie Question


#1

I have downloaded Pi-Aware onto my Raspberry Pi 2 and everything seems to be working OK.
However, I am not seeing any MLAT aircraft although my statistics are saying that MLAT data is being received. In the list I am getting only Green or White but no Purple.
I am in an area with with a number of other Pi-Aware sites quite close by.
Am I doing something wrong?

If I need to download/make changes to my Pi, please give full instructions as I am very new to this although I am skilled with MS windows

Thanks
Dave

http://www.donnyradar.co.uk


#2

Hi Dave,
I suspect a port setting mismatch between dump1090 and piaware. Can you tell us exactly how you installed dump1090 (which flavour and version) and piaware (also with version info please)? And run this from a shell to see which ports (starting with 30) are open for listening:


sudo netstat -anp | grep 30...


#3

Hi mgunther

I used piaware-sd-card-2.1-3.img for the installation
dump 1090 reports ver : flightaware-1.2-3
piaware : 2.1-5

Ports 30001 30002 30003 & 30005 are open for listening

Regards
Dave


#4

OK, PiAware should back-feed MLAT positions to dump1090 on port 30104. See here:
https://discussions.flightaware.com/ads-b-flight-tracking-f21/piaware-2-1-3-released-t36047.html

Please restart PiAware and check /tmp/piaware.out
It should tell you which port it is trying to connect to for the MLAT output (either 30004 or 30104).


sudo /etc/init.d/piaware restart

I’m not sure why your dump1090 is not listening on either 30004 (the old default) or 30104 (the new default).

Are you using the FA-supplied dump1090 that came with the sd card image? Or did you change to dump1090-mutability?


#5

Are you using the FA-supplied dump1090 that came with the sd card image?

Yes

check /tmp/piaware.out

01/09/2016 12:12:14 piaware version 2.1-5 is running, process ID 3873
01/09/2016 12:12:14 your system info is: Linux piaware 4.1.7-v7+ #817 SMP PREEMPT Sat Sep 19 15:32:00 BST 2015 armv7l GNU/Linux
01/09/2016 12:12:14 Connecting to FlightAware adept server at piaware.flightaware.com/1200
01/09/2016 12:12:14 ADS-B data program ‘dump1090’ is listening on port 30005, so far so good
01/09/2016 12:12:14 Starting faup1090: /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --stdout --lat 53.536 --lon -1.098
01/09/2016 12:12:14 Started faup1090 (pid 3896) to connect to dump1090
01/09/2016 12:12:14 Connection with adept server at piaware.flightaware.com/1200 established
01/09/2016 12:12:14 FlightAware server SSL certificate validated
01/09/2016 12:12:14 encrypted session established with FlightAware
01/09/2016 12:12:14 autoUpdate is not set in adept config, looking further…
01/09/2016 12:12:14 autoUpdate in /etc/piaware is enabled, allowing update
01/09/2016 12:12:14 manualUpdate is not set in adept config, looking further…
01/09/2016 12:12:14 manualUpdate in /etc/piaware is enabled, allowing update
01/09/2016 12:12:14 multilateration support enabled (use piaware-config to disable)
01/09/2016 12:12:15 piaware received a message from dump1090!
01/09/2016 12:12:15 logged in to FlightAware as user amagicdrag0n
01/09/2016 12:12:15 multilateration support enabled (use piaware-config to disable)
01/09/2016 12:12:15 multilateration data requested, enabling mlat client
01/09/2016 12:12:15 Starting multilateration client: /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --results beast,connect,feed.adsbexchange.com:30005 --udp-transport 70.42.6.197:9559:4060977575
01/09/2016 12:12:15 mlat(3901): fa-mlat-client 0.2.4 starting up
01/09/2016 12:12:15 mlat(3901): Using UDP transport to 70.42.6.197:9559
01/09/2016 12:12:16 mlat(3901): Input connected to localhost:30005
01/09/2016 12:12:16 mlat(3901): Beast-format results connection with feed.adsbexchange.com:30005: connection established

Open ports are

pi@piaware ~ sudo netstat -anp | grep 30... tcp 0 0 0.0.0.0:30001 0.0.0.0:* LISTEN 2039/dump1090 tcp 0 0 0.0.0.0:30002 0.0.0.0:* LISTEN 2039/dump1090 tcp 0 0 0.0.0.0:30003 0.0.0.0:* LISTEN 2039/dump1090 tcp 0 0 0.0.0.0:30005 0.0.0.0:* LISTEN 2039/dump1090 tcp 0 0 0.0.0.0:30104 0.0.0.0:* LISTEN 2039/dump1090 tcp 0 318 192.168.0.24:60057 167.114.60.74:30005 ESTABLISHED 2397/nc tcp 0 0 127.0.0.1:38292 127.0.0.1:30005 ESTABLISHED 4033/fa-mlat-client tcp 56 0 127.0.0.1:38291 127.0.0.1:30005 ESTABLISHED 4028/faup1090 tcp 0 0 192.168.0.24:60076 167.114.60.74:30005 ESTABLISHED 4033/fa-mlat-client tcp 0 0 127.0.0.1:38273 127.0.0.1:30005 FIN_WAIT2 2396/nc tcp 0 0 127.0.0.1:30005 127.0.0.1:38292 ESTABLISHED 2039/dump1090 tcp 1 0 127.0.0.1:30005 127.0.0.1:38273 CLOSE_WAIT 2039/dump1090 tcp 0 32 127.0.0.1:30005 127.0.0.1:38291 ESTABLISHED 2039/dump1090 pi@piaware ~


#6

You have configured piaware to send mlat results to adsbexchange, but not to send them to your local dump1090 which is why you don’t see any mlat locally.


#7

You have configured piaware to send mlat results to adsbexchange, but not to send them to your local dump1090 which is why you don’t see any mlat locally.

Ah!!! Thank you I understand, so is it possible to do both?


#8

The following should do it:


sudo piaware-config -mlatResultsFormat "beast,connect,localhost:30104 beast,connect,feed.adsbexchange.com:30005"

Restart piaware just in case and check the piaware.out log again.

Edit: add closing quote to command.


#9

sudo piaware-config -mlatResultsFormat "beast,connect,localhost:30104 beast,connect,feed.adsbexchange.com:30005

Sorry to say that didn’t work. Pi just hung

pi@piaware ~ $ sudo piaware-config -mlatResultsFormat "beast,connect,localhost:30104 beast,connect,feed.adsbexchange.com:30005


#10

looks like you are missing a close quote at the end "


#11

Yeah, sorry, missed out on the closing quote during copy/paste. Edited now.


#12

That has sorted the problem :smiley: :smiley:

Thanks to everyone and especially mgunther for all you help

Regards
Dave
http://www.donnyradar.co.uk