FlightAware Discussions

Newbie Howto and Advice on Feeding FR24

Greetings,
Bear with me here. New to feeding.
I have set up my Raspberry Pi 3B+, with PiAware image 3.6.3.
Been feeding FA for the past 2 months or so with no issues.
I’ve also turned on SSH and managed to login with Putty.

I researched adding my feed to FR24 and it seems that all that is required is to SSH into Raspberry Pi and execute this line of code:
sudo bash -c “$(wget -O - https://repo-feed.flightradar24.com/install_fr24_rpi.sh)”

Answer a few questions etc.
Is it really as simple as this?
Any advice for a newbie?

Thanks

It seems the current install script even automatically detects if something is providing data on 30005 and offers automatic configuration which seems to do the right thing.
(Haven’t tested it personally)

In case of manual configuration select Beast / TCP and point it at 127.0.0.1 at port 30005.

The important thing is NOT selecting DVB-T/USB, this will try to use an fr24 internal dump1090 and not provide data to other feed clients like piaware.

Nothing more to it.

1 Like

When configuring fr24feed, do NOT use setting Receiver DVB-T.

Use Receiver Beast(TCP), host/ip 127.0.0.1:30005

.

1 Like

It seems the automatic configuration uses AVR-TCP on port 30002 i just checked on my Rpi.

I’d just choose to use beast-tcp but it really doesn’t matter.

Yes, you are right. The default of fr24feed is avr-tcp port 30002, but I always use beast-tcp port 30005.

This is default setting. I dont understand why they prefer AVR over BEAST

I just checked both formats and they contain exactly the same information.

Beast is binary and therefore uses less bandwidth i believe but as it’s being transmitted on the same computer it doesn’t matter.

@wiedehopf
Nothing to do with current subject, but I notice a stupid behaviour of Pi24 image which uses its dump v1.14.

If at startup, the fr24feed detects no version of dump1090, it starts its own dump1090.

If it detects another version of dump1090 installed, it does NOT start its own dump1090.

So far so good.

When opensky feeder is installed, its binary /usr/bin/openskyd-1090 is detected by fr24feed as some version of dump1090, and it does not start its own dump1090. Now there is no decoder running, and all data feeders start crying no program is listening to adsb data on port 30005.

:slightly_frowning_face: :smile:

I overcame this problem by removing 1090 from the binary file name, and in service file of opensky also removed 1090 in the line ExecStart=

Oh my. That’s an interesting detection method for sure.

But as long as fr24 doesn’t just randomly grab the dongle i’m pretty much ok with whatever they do.