Multiple Feeders


#1

Folks,

I’ve touched on this before but having installed via scripts ADSBx and FR24 I am checking out what is doing what.

Mindful of FA’s mlat conditions I have been advised if feeding from port 30005 all is fine.

ADSBx appears to be using 30005 in config file but checking the FR setup it shows 127.0.0.1:30002 in the config file for HOST/IP

Is this OK?

Geffers


#2

ModeS Beast is output at 30005. That’s what I use to feed FR24.
You can change that FR24 setup by going to <feeder_IP>:8787


#3

I just used the script and altered nothing, strange.

Not sure where the FR24 config file is, the info I quoted was from the web interface at :8754 - port 8787 didn’t give me a result.

Geffers


#4

I was editing the post above :slight_smile:


#5

Sorry. Mine is also on 8754… Check the IP to be the Pi’s one, not localhost of the PC.
I was confusing with ModeSMixer.


#6

Well it shows 127.0.0.1:30002 but to access it from my laptop I typed :8754 and as previously mentioned, just accepted defaults from script file.

Geoff


#7

Those defaults are bad for our combined installation, they work only for their stand-alone.


#8

(1) IP-OF-PI:8754/settings.html reads from config file, and if save button on this page is clicked, saves the currently displayed/edited settings to config file.

.
(2) This is the config file:
/etc/fr24feed.ini

.
(3) The default contents of config file are

cat /etc/fr24feed.ini
receiver="avr-tcp" 
fr24key="xxxxxxxxxxxxxxxx" 
host="127.0.0.1:30002" 
bs="no" 
raw="no" 
logmode="1" 
logpath="/var/log/fr24feed" 
mlat="yes" 
mlat-without-gps="yes"

.
(4) Any one of the following two settings work ok

Default
receiver=“avr-tcp”
host=“127.0.0.1:30002”

.
Alternate
receiver=“beast-tcp”
host=“127.0.0.1:30005”

.


#9

At some point the avr-tcp with 30002 didn’t work for me… not sure if it works now.


#10

You are right. This problem persisted during 2016/2017, but is now over.

The contents of file /etc/fr24.ini which I posted in my above post are from my current working install on Piaware SD card image 3.6.2. This was done shortly after Piawsre SD card image ver 3.6.2 was released, so it is hardly few weeks old.


#11

@send2gl
@SoNic67

The current bug in FR24 feeder is its failure to connect to FR24 server if it tries IPv6 address. This is totally due to some bug in their servers. I am not sure if it is solved or still there.

If you face an error message of failure to connect, see the 2 bug-fixes given below

Fix #1
As a temporary measure, FR24 admin suggested to block IPv6 by giving this command

sudo sysctl -w net.ipv6.conf.all.disable_ipv6=1

However this command is to be re-issued at every reboot of Pi.

.
Fix #2
A FR24 forum member gave a better solution. Instead of totally blocking IPv6, he suggested following method to change preference to IPv4. I have tested it, and it works fine. Here is this method:

sudo nano /etc/gai.conf 

In this file scroll down to find following line:

#precedence ::ffff:0:0/96 100
Uncomment this line so it looks like:
precedence ::ffff:0:0/96 100
Now Pi will prefer IPv4

Restart fr24feed

sudo systemctl restart fr24feed

#12

Maybe in fancy Canada you have IPv6, but here in US, Verizon FIOS decided that’s not cool to have :smiley:

LE: Although my router shows only IPv4, looks like they are starting now to provide some IPv6: https://www.verizon.com/support/residential/internet/getting-started/learn-about-ipv6


#13

I have been waiting for FIOS to get it for over 5 years.
I remember doing training on IPV6 in the late 1990s in Cisco and Nortel courses.

I currently have my router tunnel IPV6 through https://www.tunnelbroker.net/
This way all devices on my Network can use it. It is a old Cisco 891 but some of the residential routers also support tunnels. The only issue I have is changing the tunnel IP when Verizon change my router’s external IP.


#14

So, just touching on my original query, my FR24 feed currently shows as operating via port 30002 - I am assuming there is no conflict with FlightAware’s MLAT.

Or should I change config to receiver=“beast-tcp” host=“127.0.0.1:30005” ?

I have currently got MLAT disabled for FA but this is not my main R-Pi set up, it is intended for relocation.

Geoff


#15

Like I said, the (avr-tcp, 30002) didn’t work for me in the past, so I have switched to (beast-tcp, 30005) and never looked to change it.
You can see if it really works for you on that admin port <IP_Pi>:8754 , it will show the number of Aircraft Tracked and Uploaded.
If you don’t see anything on that port, your setup is incomplete.
See also: