FlightAware Discussions

New user, RAW data feeding question

I have already setup feeding FR24 on rpi2 and everything is working.

Can I use the RAW data from this rpi to another one running PiAware? I setup the FR24 with RAW data enabled on port:30002 and data feed port:30003

I’m asking as I have a number of RPIs already on the network doing other tasks and would like to keep FR24 and FA separate if possible. Is there is guide I could follow to achieve this?

Thank you for any advice.

This will transition you to a proper decoder (dump1090-fa instead of outdated dump1090-mutability).

https://github.com/wiedehopf/adsb-scripts/wiki/Bundle-install-for-dump1090fa

piaware requires beast data (port 30005)
After you run the script above, you can install piaware like this:

sudo apt install piaware

And you’re done.
FR24 will be reconfigured by the script to use data from 30005 as well.
This way even if FR24 crashes or w/e, you still have data.
Much more reliable this way.

Many thanks, I’ll take time to read up and digest and see if I can get it working this way.

Update:

I’ve run the linked script from github on pi-1 (already working with FR24) and it completed. Rebooted

On pi-2 I’ve installed piaware and rebooted.

So I need to do some troubleshooting, when I run piaware I see the following:

piaware
2020-05-15 08:02:20Z warning: /etc/piaware.conf: failed to read config file: couldn’t open “/etc/piaware.conf”: permission denied
2020-05-15 08:02:20Z failed to reopen /var/log/piaware.log: couldn’t open “/var/log/piaware.log”: permission denied
2020-05-15 08:02:20Z ****************************************************
2020-05-15 08:02:20Z piaware version 3.8.1 is running, process ID 6840
2020-05-15 08:02:20Z your system info is: Linux rpi4 4.19.97-v7l+ #1294 SMP Thu Jan 30 13:21:14 GMT 2020 armv7l GNU/Linux
2020-05-15 08:02:21Z Connecting to FlightAware adept server at piaware.flightaware.com/1200
2020-05-15 08:02:21Z Connection with adept server at piaware.flightaware.com/1200 established
2020-05-15 08:02:22Z TLS handshake with adept server at piaware.flightaware.com/1200 completed
2020-05-15 08:02:22Z FlightAware server certificate validated
2020-05-15 08:02:22Z encrypted session established with FlightAware
2020-05-15 08:02:22Z warning: /etc/piaware.conf: failed to read config file: couldn’t open “/etc/piaware.conf”: permission denied
2020-05-15 08:02:22Z logged in to FlightAware as user guest
2020-05-15 08:02:22Z my feeder ID is 62e3c39d-93e3-4c65-a3d9-8e81db6e16a3
2020-05-15 08:02:22Z Failed to update feeder ID file at /var/cache/piaware/feeder_id: couldn’t open “/var/cache/piaware/feeder_id.new”: permission denied
2020-05-15 08:02:23Z no ADS-B data program seen listening on port 30005 for 3 seconds, next check in 60s
2020-05-15 08:02:23Z UAT support disabled by local configuration setting: uat-receiver-type
^C2020-05-15 08:02:33Z piaware (process 6840) is shutting down because it received a shutdown signal (SIGINT) from the system…
2020-05-15 08:02:33Z piaware (process 6840) is exiting…

Is there some configuring I have yet to do?

Are you just running piaware from the command line? Don’t do that; it’s designed to be automatically started by a systemd service. It’s probably already running.

Try systemctl status piaware or look in /var/log/piaware.log.

Thank you, I rebooted both pi’s again and think its working now

pi@rpi3:~ $ systemctl status piaware
● piaware.service - FlightAware ADS-B uploader
Loaded: loaded (/lib/systemd/system/piaware.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2020-05-15 10:01:43 BST; 20min ago
Docs: https://flightaware.com/adsb/piaware/
Main PID: 869 (piaware)
Tasks: 4 (limit: 2200)
Memory: 19.9M
CGroup: /system.slice/piaware.service
├─ 869 /usr/bin/piaware -p /run/piaware/piaware.pid -plainlog -statusfile /run/piaware/status.json
├─1228 /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --stdout --lat 52.721 --lon -1.151
└─3352 /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --input-type dump1090 --results beast,connect,localhost:30104 --results b
May 15 10:08:23 rpi3 piaware[869]: mlat-client(3352): Using UDP transport to 70.42.6.224 port 14842
May 15 10:08:23 rpi3 piaware[869]: mlat-client(3352): Listening for Beast-format results connection on port 30105
May 15 10:08:23 rpi3 piaware[869]: mlat-client(3352): Listening for Extended Basestation-format results connection on port 30106
May 15 10:08:23 rpi3 piaware[869]: mlat-client(3352): Route MTU changed to 1500
May 15 10:08:23 rpi3 piaware[869]: mlat-client(3352): Input connected to localhost:30005
May 15 10:08:23 rpi3 piaware[869]: mlat-client(3352): Input format changed to BEAST, 12MHz clock
May 15 10:08:23 rpi3 piaware[869]: mlat-client(3352): Beast-format results connection with ::1:30104: connection established
May 15 10:08:47 rpi3 piaware[869]: 73 msgs recv’d from dump1090-fa (45 in last 1m); 47 msgs sent to FlightAware
May 15 10:13:47 rpi3 piaware[869]: 364 msgs recv’d from dump1090-fa (291 in last 5m); 338 msgs sent to FlightAware
May 15 10:18:47 rpi3 piaware[869]: 646 msgs recv’d from dump1090-fa (282 in last 5m); 620 msgs sent to FlightAware

Sorry I messed up the quote when replying…

I thinks its working properly now, does it look OK&