FR24 up and running for 2 years with RPi, PiAware installation not working


#1

Hello everyone,
I am feeding data to FR24 since 02/2016 with a RPi, so far with a self-made ground plate antenna, everything is fine. I bought a FlightAware antenna and a business card was coming with it, asking me to also feed to FlightAware. I was already thinking about that for a while. So I installed PiAware and I also have a link to the new created FlightAware. But:
I am not sure how to change setup of dump1090 for PiAware to get data from existing installation, there is no data at port 30005:


I tried this, not working:
– had to remove picture because of being new user
And this, not working:
– had to remove picture because of being new user
Now I am seeking for help here, because the FR24 installation is working if I switch back to the “former” setup.

Best regards,
JoRuFe


#2

This one:


FR24 not working anymore…


#3

And this one:


FR24 not working anymore…


#4

As before:
fr24port8754
Beast Setup:
fr24port8754BeastTCP
AVR Setup:
fr24port8754AVR


#5

Keep everything as it is in above screenshot, just add --net --net-bi-port 30104 in field Process arguments (where you have --lat 47. --lon 9. `), Save, and Restart.


#6

@JoRuFe:
Please see my following post for details:

21-01-2018: How I Configured Pi24 To Run Piaware Data feeder + Display Flightaware MLAT Feed Back on Map


#7

Thanks. Seems to be working. Good to see the same always helping hand here too. I will let the night build up the first stats. Good night from Germany.


#8

I added the option:
–aggressive : CPU seems not be too much impressed… CPU is still below 20% but no improvements to see actually in numbers or range. Does it make any sense though?
What about gain control? Do anything there? S/th like:
–gain Set gain (default: max gain. Use -10 for auto-gain)
–enable-agc Enable the Automatic Gain Control (default: off)

Thx for any ideas. Does it only work with the FA sticks? I have ordered the blue and the orange, just to check or have a lab installation…


#9

It works with DVB-T as well as with Pro Stick.

Screenshot below shows settings when dump1090 (mr) was in use by FR24 and showed the map on port 8080.

Do not use the setting –net-http-port 8888, as now dump1090-mutability v1.14 is used by FR24, and map is displayed at ip-of-pi/dump1090/gmap.html

All other settings remain unchanged. Note the gain setting is also in “Process arguments” field.

.


#10

Alternatively instead of entering “Process arguments” in the settings page, you can add these by following two alrernative methods:
.

Alternative-1

sudo nano /etc/fr24feed.ini

The above command will open following file for editing. You can change settings, Save file, then restart fr24feed

receiver="dvbt"
fr24key="xxxxxxxxxxxx"
path="/usr/lib/fr24/dump1090"
bs="no"
raw="no"
logmode="1"
windowmode="0"
logpath="/var/log"
mpx="no"
mlat="yes"
mlat-without-gps="yes"
procargs="--net  --net-bi-port 30104  --gain 40" 

.

Save changes (Ctrl+o), Close editor (Ctrl+x), and restart fr24feed

sudo systemctl restart fr24feed
.

Alternative-2

sudo nano /etc/default/dump1090-mutability

Above command will open this following file where you can change config settings.

# dump1090-mutability configuration file
# This is a POSIX shell fragment.
# You can edit this file directly, or use
# "dpkg-reconfigure dump1090-mutability"

# Set to "yes" to start dump1090 on boot.
START_DUMP1090="no"

# User to run dump1090 as.
DUMP1090_USER="dump1090"

# Logfile to log to
LOGFILE="/var/log/dump1090-mutability.log"

#
# Receiver options
#

# RTLSDR device index or serial number to use
# If set to "none", dump1090 will be started in --net-only mode
DEVICE=""

# RTLSDR gain in dB.
# If set to "max" (the default) the maximum supported gain is used.
# If set to "agc", the tuner AGC is used to set the gain.
GAIN=40

# RTLSDR frequency correction in PPM
PPM="0"

#
# Decoding options
#

# If yes, fixes messages with correctable CRC errors.
FIX_CRC="yes"

# If set, supplies a reference location for local position decoding.
LAT="43.xxxx"
LON="-79.xxxx"

# If set, provides the absolute maximum receiver range used to
# filter bad position reports, and to determine when local position
# decoding is safe to use. Specify this in nautical miles (NM).
MAX_RANGE="300"

#
# Networking options
#

# Port to listen on for raw (AVR-format) input connections. 0 disables.
RAW_INPUT_PORT="30001"

# Port to listen on for raw (AVR-format) output connections. 0 disables.
RAW_OUTPUT_PORT="30002"

# Port to listen on for SBS-format output connections. 0 disables.
SBS_OUTPUT_PORT="30003"

# Port to listen on for Beast-format input connections. 0 disables.
BEAST_INPUT_PORT="30004,30104"

# Port to listen on for Beast-format output connections. 0 disables.
BEAST_OUTPUT_PORT="30005"

# TCP heartbeat interval in seconds. 0 disables.
NET_HEARTBEAT="60"

# Minimum output buffer size per write, in bytes.
NET_OUTPUT_SIZE="500"

# Maximum buffering time before writing, in seconds.
NET_OUTPUT_INTERVAL="1"

# TCP buffer size, in bytes
NET_BUFFER="262144"

# Bind ports on a particular address. If unset, binds to all interfaces.
# This defaults to binding to localhost. If you need to allow remote
# connections, change this.
#NET_BIND_ADDRESS="127.0.0.1"

#
# Misc options
#

# Interval (in seconds) between logging stats to the logfile. 0 disables.
STATS_INTERVAL="3600"

# Path to write json state to (for use with an external webserver). Blank disables.
JSON_DIR="/run/dump1090-mutability"

# Interval between writing json state (in seconds). 0 disables.
JSON_INTERVAL="1"

# Accuracy of receiver location to write to json state, one of "exact" / "approximate" / "none"
JSON_LOCATION_ACCURACY="approximate"

# Set to yes to log all decoded messages
# This can get large fast!
LOG_DECODED_MESSAGES="no"

# Additional options that are passed to the Daemon.
EXTRA_ARGS=""

.

Save file (Ctrl+o), Close editor (Ctrl+x), and restart

sudo systemctl restart dump1090-mutability

sudo systemctl restart fr24feed

#11

Thx abcxd567 for the shown options. I changed the parameters back to “–lat 47.xxx --lon 9.xxx --net --net-bi-port 30104” and will leave it alone for a couple of days to watch. It will take approx. 2-3 weeks for the FA sticks (blue and orange) to arrive from the US here in Germany as the big A tells me. I will try some fiddling then. I changed my antenna from a homemade spider (picture is in the FR24 thread: https://forum.flightradar24.com/threads/8596-3-EASY-ANTENNAS-FOR-BEGINNERS?p=76877&viewfull=1#post76877) to the FA antenna. This gave not so big of a difference: around 8-10 nm max. range improvement (according to the FR24 stats, 170->178 nm), I don’t have the impression to have much more contacts either: probably a location issue :slight_smile:
I saw the possible parameters of dump1090 using ./dump1090 --help in a SSH terminal (see GitHub).


#12

Yes, likely.

You can determine maximum range achieveable at your antenna location and height by following the method shown in FIRST post of this thread:

What is the Maximum Range I can Get?

This will give you a reference to judge how good is your current setup, and how much further you can improve.