My piaware is dead! 😩


#1

I have been continuously feeding the data from my PiAware device for a last couple of days. Everything was going fine, plenty of aircrafts tracked, until today morning when my Raspberry got disconnected from my wifi network today and I found that my RPi was dead. Tried reviving it again and again but no success. I have no clue what to do now. I don’t have a spare RPi to feed my data to FlightAware.

My request for FlightFeeder was recently approved but it is still pending shipment. I am from India, anyone from India can tell me how long did it take to get your FlightFeeder device after approval.

Feeling SAD and left CLUELESS !! :cry:


#2

The consensus here is that the most common point of failure is the PSU.
Small phone chargers (particularly cheap/no-brand) units are not long lived when powering a Pi 24/7.

Does you Pi give any sign of life?


#3

@geckoVN
I am using my cell phone charger which is rated at 5V/1A. Today my RPi booted but again it went into some unconscious state with only the red light on. This happens again and again. It boots up for some time as if everything is fine and then it passes out all of a sudden with the red light still and the light on the rtl sdr still on. What may have happened any idea?


#4

replace power supply
2.5A recommended


#5

@geckoVN @rugomol
One thing I noticed today and that is the heat sink atop the main Broadcom processor on my RPi is heating abnormally. Is my RPi getting a thermal shutdown? Is this common with RPi if it is getting overloaded? Please reply.


#6

The abnormal strong heating of the chip is usually a sign of its failure. Something like a short circuit inside the chip. For example, after a lightning strike.


#7

@rugomol
But I have an antenna that lies on my table indoors so lightening must not be a problem I suppose. I have a 5V/2A charger, will it suffice in a long run?


#8

Most problems can be found using the console https://elinux.org/RPi_Serial_Connection

In case of a problematic power supply, this device will stop loading the operating system or hangs or freezes. it will be seen on the console

It is also useful to measure the supply voltage while the RPi is running.


#9

I’ve just tossed two phone chargers the worked fine for several months, but then went ‘soft’. If the PSU is cold, it works fine, but after a short time the output would drop to 4.2V and the Pi would blink a bit, but not do anything useful.Without measuring to output (under load) I would have assumed the PSU was ok.


#10

заменить источник питания
2.5A рекомендуется


#11

The Raspberry Pi works similar to a desktop computer in that you can hook up a HDMI monitor , keyboard, mouse. After booting it will display either a command line or a desktop screen depending on the OS you have installed.

If the Raspberry Pi doesn’t boot then check if the RED LED is on.
constant red LED = has enough power to run
blinking red LED = marginal power to run
off red LED = power problem

Then check if the green LED is blinking.
blinked green LED = SD card is being read from (LED should blink a lot during boot up and less while running)
off green LED = SD card is not being read from

If you have a constant RED LED and a blink green LED the HDMI should be on.
Rainbow HDMI screen = OS couldn’t load, this screen is generated by the CPU and not by the SD card.
Command prompt or Desktop = OS loaded

One thing I noticed today and that is the heat sink atop the main Broadcom processor on my RPi is heating abnormally. Is my RPi getting a thermal shutdown?

The Broadcom processor gets to around 40-50C while running. This is normal. The CPU should be around 20C higher than ambient temperature.
Thermo throttling is around 60C-80C (very gradual reduction at first and then more throttling at higher temps)
Thermo shutdown is above 80C (can cause a burn within a second of touching).

Circuits can be damaged by voltage spikes. It is always suggested that computers are connected to a surge protector.


#12

i appear to be a new addition to the RPI is dead club. i was sitting watching flights and got a “AJAX call failed” message. when over and looked at the RPI (3B model) and red light was on but green not flashing (green off). i put my finger on the headsink (ouch), very hot but i have a small fan running on it and the rtlsdr dongle, both usually easy to touch. i powered down for a few minutes and restarted…still red light but no green. (i use an external bias-t and measured about 4.8vdc( i use the 5vdc from the RPI so RPI power still working). i usually see right at 5vdc so a little drop.
i then pulled the SD card and re-inserted…still no joy…just ordered a new RPI 3B from amazon…will also burn a new SD card in the am (i just noticed it is the cocktail hour here so no more fussing tonight…what a pain)