Today, my home suffered a brief power loss causing the PiAware RPi lose power. I found out about it nine hours later.

My current (and only) streak is 875 days. This isn’t just luck. I’ve invested a great deal of time, effort and some cash to ensure it stays running. If it happens to be one of those days when I can’t check it frequently, I know that FA will send me an email after six hours that it is down. NOT! Only after reading through the forum today did I find that this feature has been suspended until you can get your stats act together. Don’t you thing this would have been something worth telling your feeders about? You send me other emails and news letters. Some sort of mailing, announcement or banner stating this suspension was in effect would have been nice.

And then there is this nonsense:

Does anybody test this stuff or look at it to make sure it makes sense?

My RPi was OFF yet, as you can see, the message states Piaware is running and MLAT is synchronized.

Please people, do some testing.

1st world problems.

:smiley: :smiley: :smiley:

Take a chill pill and relax, it’s not like its life and death mission critical …

If it is so important to you, a 30 second Google search reveals how to monitor your processes on your RPI. … processes/

No need to panic. This is happening with me also.
It is caused by lag in statistic update by Flightaware server, and will get corrected in due course.
I dont think it is going to cause a break in streak.

In my case my feeder was definitely off due to a power hit, not a stats overload issue.

I do have many checks locally to insure the feeder is running but the power hit caused an issue with the switch in my network so the RPi doing the monitoring could not send the email. Having the Flightaware 6 hour warning would certainly would have been helpful.

The main crux of the post was to show the inconsistancies with the red and green boxes as shown in the screenshots.

To the poster that mentioned the “chill pill”, you should have seen my first draft :slight_smile:


UPDATE: I found that my situation, apparently same as TD’s, was caused by an entirely different event, and had nothing to do with lag in update of stats by FA server. Please read details below.

Noticing that even after 12 hrs, the “Flightaware” button on stats page is still showing red, I became suspecious it is not due to lag in stats update, but is caused by my yesterday’s swaping of Pis, and associated mac address spoof removal from current Pi by editing file “cmdline.txt”. This is what I have done yesterday:

pi@raspberrypi:~ $ sudo nano /boot/cmdline.txt
#removed part “smsc95xx.macaddr=xx:xx:xx:xx:xx:xx”

About 15 minutes ago, in order to correct the mess created by mac address spoof removal, I gave following commands:

pi@raspberrypi:~ $ sudo rm /var/cache/piaware/feeder_id
pi@raspberrypi:~ $ sudo reboot

Above commands did not solve the problem. So I tried following:

pi@raspberrypi:~ $ sudo nano /etc/piaware.conf

removed value of feeder-id from the line “feeder-id xxxxxxxx-xxxx–xxxx-xxxxxxxxxxxx # updated by fa_piaware_config”

#saved file

pi@raspberrypi:~ $ sudo rm /var/cache/piaware/feeder_id
pi@raspberrypi:~ $ sudo reboot

This worked, and now “Flightaware” button is also green like other two buttons.